Details
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Suggestion
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Resolution: Unresolved
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None
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73
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108
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Description
NOTE: This suggestion is for Confluence Server. Using Confluence Cloud? See the corresponding suggestion.
Hi all,
Many thanks for all your votes and comments on this suggestion, and apologies for not providing you with a response in such a long period of time.
We fully understand the frustration with this issue, and understand the difficulties involved in your users and customers not being able to easily switch between two products when they’re not registered users for both.
As most of you are aware, the current workarounds for this issue involve opening the Confluence link either in a new browser, or an incognito window.
This is an improvement we want to implement in the future, but it's not on our roadmap for the next 12 months. We’re instead investigating other improvements related to our permissions model, such as the behaviour of inherited page edit permissions (CONFSERVER-5095) and the ability to open up individual pages to specific users (CONFSERVER-37884) and ([CONFSERVER-7089).
Best,
Jenny Millman | Product Manager - Confluence Server
Problem Definition
If a user (e.g. a JIRA user) is not licensed to use Confluence, they cannot view any Confluence content (from JIRA or Service Desk for instance) - even if that content is available to anonymous users. They currently have to log out before they can see the content. Customers have also asked for anonymous, read-only access for authenticated users that are not coming from a JIRA User Directory.
Suggested Solution for non-Service Desk customers
We cannot allow authenticated but unlicensed users to edit anonymously accessible content, since that would mean that admins would only have to enable anonymous access to have the equivalent of an unlimited user license.
Instead, we should allow authenticated but unlicensed users to get read-only access to confluence content with anonymous permissions.
Such users will still be locked out from parts of the application that require a licensed user, including viewing user profiles, people directories, etc, unless anonymous has been granted permission to view user profiles.
Solution for JIRA Service Desk customers
Link JIRA Service Desk project to Confluence space to allow customers to have access to knowledge base in Project Settings -> Knowledge Base.
Attachments
Issue Links
- causes
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CLOUD-6749 User with application access to JIRA only is unable to browse public Confluence page in the same session
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- Closed
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CLOUD-6604 Users without Confluence application access cannot see Confluence pages with anonymous access
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- Closed
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JSDSERVER-3539 Anonymous access to a confluence space doesn't allow service desk customer to view
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- Closed
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QUALITY-381 Loading...
- incorporates
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JRASERVER-38495 Remote link to unrestricted confluence pages or spaces fails for JIRA users who do not have login credentials for confluence
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- Closed
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- is duplicated by
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CONFSERVER-2871 No user should have less permissions than Anonymous
- Closed
- is related to
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CLOUD-6604 Users without Confluence application access cannot see Confluence pages with anonymous access
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- Closed
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JSDCLOUD-5056 Service Desk customers no longer able to access public confluence spaces
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- Closed
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JSDCLOUD-5264 JIRA Users unable to view attachments on Confluence KBs without Confluence global permission
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- Closed
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CONFSERVER-41227 Livesearch macro returns Not Permitted when Unlicensed Access searching
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- Gathering Impact
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JST-133597 Loading...
- relates to
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CONFCLOUD-30161 Allow unlicensed, authenticated users to have anonymous read only access
- Closed
- mentioned in
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