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Suggestion
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Resolution: Unresolved
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None
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73
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108
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Hi everyone,
Thank you for your interest in this suggestion. We’ve reviewed this since the last update, and understand that the current behaviour for unlicensed, authenticated users is unintuitive. While it may appear simple on the surface, making changes to permissions always tends to be a complex undertaking. At this time, we do not have an update as to when we’ll work on this, though we will keep it open for future consideration, and will share any updates here.
To learn more about our recent investments in Confluence Data Center, please check our public roadmap and our dashboards containing recently resolved issues, and current work.
Kind regards,
Jacqueline Bietz
Product Manager
Confluence Data Center
Problem Definition
If a user (e.g. a JIRA user) is not licensed to use Confluence, they cannot view any Confluence content (from JIRA or Service Desk for instance) - even if that content is available to anonymous users. They currently have to log out before they can see the content. Customers have also asked for anonymous, read-only access for authenticated users that are not coming from a JIRA User Directory.
Suggested Solution for non-Service Desk customers
We cannot allow authenticated but unlicensed users to edit anonymously accessible content, since that would mean that admins would only have to enable anonymous access to have the equivalent of an unlimited user license.
Instead, we should allow authenticated but unlicensed users to get read-only access to confluence content with anonymous permissions.
Such users will still be locked out from parts of the application that require a licensed user, including viewing user profiles, people directories, etc, unless anonymous has been granted permission to view user profiles.
Solution for JIRA Service Desk customers
Link JIRA Service Desk project to Confluence space to allow customers to have access to knowledge base in Project Settings -> Knowledge Base.
- causes
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CLOUD-6749 User with application access to JIRA only is unable to browse public Confluence page in the same session
- Closed
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CLOUD-6604 Users without Confluence application access cannot see Confluence pages with anonymous access
- Closed
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JSDSERVER-3539 Anonymous access to a confluence space doesn't allow service desk customer to view
- Closed
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QUALITY-381 Loading...
- incorporates
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JRASERVER-38495 Remote link to unrestricted confluence pages or spaces fails for JIRA users who do not have login credentials for confluence
- Closed
- is duplicated by
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CONFSERVER-2871 No user should have less permissions than Anonymous
- Closed
- is related to
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CLOUD-6604 Users without Confluence application access cannot see Confluence pages with anonymous access
- Closed
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JSDCLOUD-5056 Service Desk customers no longer able to access public confluence spaces
- Closed
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JSDCLOUD-5264 JIRA Users unable to view attachments on Confluence KBs without Confluence global permission
- Closed
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CONFSERVER-41227 Livesearch macro returns Not Permitted when Unlicensed Access searching
- Gathering Impact
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JST-133597 Loading...
- relates to
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CONFCLOUD-30161 Allow unlicensed, authenticated users to have anonymous read only access
- Closed
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ENT-1316 Loading...
- mentioned in
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