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Suggestion
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Resolution: Fixed
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None
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335
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36
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NOTE: This suggestion is for JIRA Service Desk Server. Using JIRA Service Desk Cloud? See the corresponding suggestion.
Problem Definition
When a customer is part of one single organization, any request created by this customer either from the UI, or by email will be automatically shared with this organization.
It can be a problem if the customer did not have any intention to share the request with the organization:
- when creating the request from the UI, the organization is selected by default so the customer needs to be aware of that and manually set the request as private
- however, when the issue is created by email, the situation is worse as the customer has absolutely no control over the fact that the request will be shared with the organization, so there is no workaround for this scenario
Suggested Solution for this feature request
- Completely turn off the Request Sharing within the user's Organization.
- Or add a new setting allowing project admins to either:
- Set any request private by default
- Or to automatically share issues created via the UI or by email with the single organization the customer is part of
Release notes for solution implemented in 4.7.x
Per https://confluence.atlassian.com/servicedesk/jira-service-desk-4-7-x-release-notes-987143432.html#JiraServiceDesk4.7.xreleasenotes-private, the 2 following changes have been introduced in 4.7.x:
- Customer portal: All new requests are private, regardless of how many organizations you’re in. You can still easily share them by choosing your organization in the drop-down menu when raising a request
- Email: If you’re part of only one organization, new requests will still be shared by default. Don’t like it? You can go to Administration > Applications > Jira Service Desk configuration, and make all requests private by default.
Please note that it is possible to disable the new behavior introduced in the Customer Portal by following the steps below:
- Navigate to the following page to access the Dark Features page:
<baseUrl>/secure/admin/SiteDarkFeatures!Default.jspa
- Enter sd.customer.share.default.private.disabled in the field Enable dark feature, click on the Add button, and verify that the dark feature sd.customer.share.default.private.disabled is listed in the page:
After you followed these steps, if a customer is a member of exactly 1 organization, this organization will be automatically selected in the request creation form (as it used to be the case before JSD 4.7.x
- causes
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JSDSERVER-6761 Backtrack 4.7 change that makes all new requests private to be configurable per project
- Closed
- is related to
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JSDSERVER-6172 As an Administrator, I want to be able to change the default value for the "Shared With" setting or disable it
- Closed
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SSE-638 You do not have permission to view this issue
- relates to
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JSDCLOUD-4382 Allow turning off sharing request with Organization by default
- Closed
- is caused by
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JSMDC-5338 You do not have permission to view this issue
- mentioned in
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All - please read/review my earlier comment above, https://jira.atlassian.com/browse/JSDSERVER-4382?focusedCommentId=1578868&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-1578868
Again, this functionality if it is setup to be automatic is deeply flawed, and the Atlassian programmers who created/propose this show they have no understandanding of the implications of it. Sure, for a bunch of programmers using Jira and/or Service Desk to record issues they might want to share them with all and sundry. But if JSD is being used by groups like HR it is an disaster waiting to happen. I would go so far as to say that for an IT person enabling the function it could be a dissmissable offense. It's that bad/serious.
The default for this functionality must be disabled, it must have to be explictly enabled, and I would go so far as to require that when someone (an administrator ONLY) turns this on then they are given a dire warning of the consequences of doing so.
Otherwise the functionality of the feature must be drastically changed.
My comments above are based on what we observed when we tested this months ago - if the functionality has already changed then we would need to be advised and we do testing again.