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Suggestion
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Resolution: Low Engagement
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None
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4
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32
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NOTE: This suggestion is for JIRA Service Desk Server. Using JIRA Service Desk Cloud? See the corresponding suggestion.
Problem Definition
As per the JIRA Service Desk 3.2.x Release Notes, it is currently not possible to upgrade directly from JIRA 6.4.x and Service Desk 2.5.9 to JIRA Core 7.2.x with JIRA Service Desk 3.2.x. Hence, customers running on JIRA 6.4.x will have to upgrade twice, increasing their downtime and also the upgrade effort to go to JIRA 7.2.x and JSD 3.2.x.
Suggested Solution
As a JIRA administrator, I would like to be able to upgrade from JIRA 6.4.x and JSD 2.5.9 to JIRA 7.2 and JIRA Service Desk 3.2 directly so that I can perform a single upgrade.
Workaround
The following jira-config.properties parameters can be used when upgrading from JIRA 6.4 to 7.0 and Service Desk 3.0:
upgrade.reindex.allowed=false jira.autoexport=false
This will cause the intermediate upgrade path ( JIRA 6.4 -> JIRA 7.0 -> JIRA 7.2 ) to occur much faster as JIRA performs an export and re-index normally as part of the upgrade which takes a long time in larger environments and is unnecessary for intermediate upgrade versions. These parameters can be removed when upgrading JIRA 7 to JIRA 7.2
- causes
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JSDSERVER-4211 Upgrading Service Desk to 3.2 from a version <= 2.5.x causes the sidebar to appear blank with an error 'unable to render element due to an error'
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- Closed
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RAID-103 You do not have permission to view this issue
- is caused by
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JSDSERVER-4732 Unable to install JSM if data exists from version prior to 3.2 upgrade steps
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- Closed
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- relates to
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JSDSERVER-4732 Unable to install JSM if data exists from version prior to 3.2 upgrade steps
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- Closed
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JSDSERVER-6538 Service Desk functionality fails with error 'You need to be a Service Desk Agent to access this page' after restoring cloud backup to server
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- Closed
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JSDCLOUD-4239 As a JIRA Service Desk administrator, I would like to be able to upgrade from JSD 2.5.9 to 3.2 directly
- Closed
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JSDS-49 Loading...
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JSDS-541 Loading...
- is related to
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SSE-360 Loading...
- links to
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[JSDSERVER-4239] As a JIRA Service Desk administrator, I would like to be able to upgrade from JSD 2.5.9 to 3.2 directly
Resolution | New: Low Engagement [ 10300 ] | |
Status | Original: Gathering Interest [ 11772 ] | New: Closed [ 6 ] |
Labels | Original: affects-server affects-upgrade pse-request ril | New: affects-server affects-upgrade cleanup-seos-fy25 pse-request ril |
UIS | Original: 5 | New: 4 |
Remote Link | Original: This issue links to "Page (Atlassian Documentation)" [ 237217 ] |
Labels | Original: affects-server affects-upgrade pse-request | New: affects-server affects-upgrade pse-request ril |
Remote Link | New: This issue links to "Internal ticket (Web Link)" [ 976701 ] |
UIS | Original: 3 | New: 5 |
UIS | Original: 5 | New: 3 |
UIS | Original: 4 | New: 5 |
Hello,
Thank you for submitting this suggestion. We appreciate you taking the time to share your ideas for improving our products, as many features and functions come from valued customers such as yourself.
Atlassian is committed to enhancing the security and compliance of our Data Center products, with an emphasis on sustainable scalability and improving the product experience for both administrators and end-users. We periodically review older suggestions to ensure we're focusing on the most relevant feedback. This suggestion has had very low engagement over the past four years, with no new watchers, votes, or comments. As a result, we're closing it for now.
We understand that this suggestion might still be important to you. If you'd like to provide additional context or information about why it remains relevant, please contact our Technical Support team for assistance. We'll be happy to review your feedback.
You can read more about our approach to highly voted suggestions here and how we prioritize what to implement here.
To learn more about our recent investments in Jira Service Management Data Center, please check our public roadmap and our dashboards, which contain recently resolved issues, current work, and future plans.
Kind regards,
Jira Service Management Data Center