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Suggestion
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Resolution: Timed out
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3
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20
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NOTE: This suggestion is for JIRA Service Desk Cloud. Using JIRA Service Desk Server? See the corresponding suggestion.
Problem Definition
As per the JIRA Service Desk 3.2.x Release Notes, it is currently not possible to upgrade directly from JIRA 6.4.x and Service Desk 2.5.9 to JIRA Core 7.2.x with JIRA Service Desk 3.2.x. Hence, customers running on JIRA 6.4.x will have to upgrade twice, increasing their downtime and also the upgrade effort to go to JIRA 7.2.x and JSD 3.2.x.
Suggested Solution
As a JIRA administrator, I would like to be able to upgrade from JIRA 6.4.x and JSD 2.5.9 to JIRA 7.2 and JIRA Service Desk 3.2 directly so that I can perform a single upgrade.
Workaround
The following jira-config.properties parameters can be used when upgrading from JIRA 6.4 to 7.0 and Service Desk 3.0:
jira.upgrade.force.manual.schedule=true jira.autoexport=false
This will cause the intermediate upgrade path ( JIRA 6.4 -> JIRA 7.0 -> JIRA 7.2 ) to occur much faster as JIRA performs an export and re-index normally as part of the upgrade which takes a long time in larger environments and is unnecessary for intermediate upgrade versions. These parameters can be removed when upgrading JIRA 7 to JIRA 7.2
- causes
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JSDCLOUD-4211 Upgrading Service Desk to 3.2 from a version <= 2.5.x breaks project navigation sidebar
- Closed
- is related to
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JSDSERVER-4239 As a JIRA Service Desk administrator, I would like to be able to upgrade from JSD 2.5.9 to 3.2 directly
- Gathering Interest
- relates to
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JSDCLOUD-4732 Add supported method for removing all JSD data from instance
- Closed