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Bug
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Resolution: Fixed
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Low
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3.3.0
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Severity 3 - Minor
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NOTE: This bug report is for JIRA Service Desk Server. Using JIRA Service Desk Cloud? See the corresponding bug report.
Summary
Webhook based on JQL does not trigger when SLA fields are used and the event set to fire the Webhook is the Issue creation event.
Steps to Reproduce
- Create a SD project
- Set a webhook based in JQL like this:
"Time to first response" = withinCalendarHours() and project = XYZ.
Set so the webhook will be triggered in the creation issue event.
Expected Results
The webhook is fired when an issue is created in the service desk if during the working hours in the calendar applied.
Actual Results
The webhook is never fired.
Workaround
No workaround, but the user may try to manipulate the date of issue creation in the JQL to meet its criteria:
created > date and created < date
- causes
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JSDSERVER-5730 OffThreadEventJobRunner job execution threads wait for their turn in a very expensive way
- Closed
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JSDSERVER-5732 OffThreadEventJobRunner uses an unbounded ThreadPoolExecutor that can exhaust the DBCP
- Closed
- relates to
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JSDCLOUD-4743 Webhook based on JQL does not trigger when SLA fields are used
- Closed
- was cloned as
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JSDS-517 Loading...