Details
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Bug
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Resolution: Fixed
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Low
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3.2.0-OD-11
Description
NOTE: This bug report is for JIRA Service Desk Server. Using JIRA Service Desk Cloud? See the corresponding bug report.
Summary
When sending an email to a Service Desk mail handler with issue key from other project (i.e JIRA SW project) entered in subject line, the email would get rejected and Service Desk mail log will state that "Service Desk you are trying to view does not exist".
Environment
- JIRA Service Desk 3.2.0-OD-11
Steps to Reproduce
- Create an issue in JIRA SW project. (i.e SW-123)
- Create a Service Desk project. (i.e SD project)
- Enable email request in Service Desk project
- Enter the issue key you've created in JIRA SW project (SW-123), in the subject line of your mail and then send it to the Service Desk mail
Expected Results
- A new Service Desk issue will be created as the issue key entered in the subject line doesn't exist in the Service Desk project.
Actual Results
- Service Desk project would reject that ticket and state that the "Service Desk you are trying to view does not exist". Somehow, it searches for the issue key even from other projects.
Attachments
Issue Links
- causes
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JSDSERVER-4335 Mail Handler wrongly creates new issue instead of adding comment to an issue moved to a different project
- Closed
- is related to
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JSDSERVER-5263 Create a new Service Desk (SD) issue when an email is received in a SD project with a non-SD issue number in the subject (DON'T add a comment to the non-SD issue)
- Gathering Interest
- relates to
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JSDCLOUD-3843 JIRA Service Desk mail handler rejects any email with issue key from other projects entered in the subject line.
- Closed
- is cloned by
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TESLA-633 Loading...