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Suggestion
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Resolution: Unresolved
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None
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4
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9
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NOTE: This suggestion is for JIRA Service Desk Server. Using JIRA Service Desk Cloud? See the corresponding suggestion.
Problem Definition
Currently, when an email have emoticons in it, the issue creation will be rejected by JIRA Service Desk if MySQL is used as the JIRA database.
In the log, the following error should be seen:
Caused by: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:INSERT INTO jiraissue (ID, pkey, issuenum, PROJECT, REPORTER, ASSIGNEE, CREATOR, issuetype, SUMMARY, DESCRIPTION, ENVIRONMENT, PRIORITY, RESOLUTION, issuestatus, CREATED, UPDATED, DUEDATE, RESOLUTIONDATE, VOTES, WATCHES, TIMEORIGINALESTIMATE, TIMEESTIMATE, TIMESPENT, WORKFLOW_ID, SECURITY, FIXFOR, COMPONENT) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) (Incorrect string value: '\xF0\x9F\xA4\x94\x0D\x0A...' for column 'DESCRIPTION' at row 1)
Cause
This is because email emoticons use 4-byte characters, while MySQL doesn't support this:
Suggested Solution
JIRA Service Desk should auto render the emoticons as text, so that issues will be successfully created.
This will also work if 4-byte characters are supported in MySQL.
Workaround
Switch to a different type of supported databases: Postgre, MS SQL, or Oracle.
- duplicates
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JSDSERVER-3452 Customer can't raise an issue when he adds an emoji in his text
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- Closed
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- is incorporated by
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JRASERVER-36135 Add support for 4 byte characters in MySQL connection
- Closed
- relates to
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JSDCLOUD-3411 As admin, would like issue creation from email accept email with emoticon
- Closed
- links to