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Bug
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Resolution: Fixed
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High
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2.5.3
NOTE: This bug report is for JIRA Service Desk Server. Using JIRA Service Desk Cloud? See the corresponding bug report.
Issue Summary:
If an agent is also a customer and he closes an issue that he raised from within JIRA (NOT Customer Portal). If there is a comment added in the resolve issue screen, the issue closes and then re-opens.
Steps to reproduce
- Create an issue as an agent in SD
- Assign the issue to yourself.
- Resolve and close the issue.
- Refresh the page.
Expected Result
Issue stays resolved based on selected resolution.
Actual Result
Issue gets resolved and gets re-opened immediately.
Cause
- The arrangement of the workflow post functions, places transitioning the issues in a higher position above add comment. (related to the order described here.
Workaround
- Edit the Transition on comment Automation Rule at
- https://<BASE_URL>.atlassian.net/servicedesk/agent/<PROJECT_ID>/settings/automation
- Manually add in the following (See screenshot):
ELSE IF issue matches: Status = Resolved and "Customer Request Type" is not empty Comment is Public User is customer THEN Transition Issue Reopen Issue
- has a regression in
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JSDSERVER-4348 Automation Re-open on comment immediately when an issue is resolved with comment added
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- Closed
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- relates to
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JSDCLOUD-2245 Automation Re-open on comment broken
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- Closed
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- was cloned as
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IL-106 Failed to load
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QUALITY-343 Failed to load
Form Name |
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[JSDSERVER-2245] Automation Re-open on comment broken
Workflow | Original: JSD Bug Workflow v5 - TEMP [ 2304588 ] | New: JAC Bug Workflow v3 [ 3125049 ] |
Status | Original: Done [ 10044 ] | New: Closed [ 6 ] |
Workflow | Original: JSD Bug Workflow v5 [ 2058433 ] | New: JSD Bug Workflow v5 - TEMP [ 2304588 ] |
Workflow | Original: JSD Bug Workflow v5 - TEMP [ 2055496 ] | New: JSD Bug Workflow v5 [ 2058433 ] |
Workflow | Original: JSD Bug Workflow v5 [ 1955259 ] | New: JSD Bug Workflow v5 - TEMP [ 2055496 ] |
Workflow | Original: JSD Bug Workflow v4 [ 1615791 ] | New: JSD Bug Workflow v5 [ 1955259 ] |
Description |
Original:
h5. Issue Summary:
If an agent is also a customer and he closes an issue that he raised from within JIRA (NOT Customer Portal). If there is a comment added in the resolve issue screen, the issue closes and then re-opens. *Steps to reproduce* - Create an issue as an agent in SD - Assign the issue to yourself. - Resolve and close the issue. - Refresh the page. *Expected Result* Issue stays resolved based on selected resolution. *Actual Result* Issue gets resolved and gets re-opened immediately. *Cause* - The arrangement of the workflow post functions, places transitioning the issues in a higher position above add comment. (related to the order described [here|https://confluence.atlassian.com/display/JIRACLOUD/Advanced+workflow+configuration]. h3.Workaround - Edit the *Transition on comment* Automation Rule at -- {{https://<BASE_URL>.atlassian.net/servicedesk/agent/<PROJECT_ID>/settings/automation}} - Manually add in the following (See screenshot): {code} ELSE IF issue matches: Status = Resolved and "Customer Request Type" is not empty Comment is Public User is customer THEN Transition Issue Reopen Issue {code} |
New:
{panel:bgColor=#e7f4fa} *NOTE:* This bug report is for *JIRA Service Desk Server*. Using *JIRA Service Desk Cloud*? [See the corresponding bug report|http://jira.atlassian.com/browse/JSDCLOUD-2245]. {panel} h5. Issue Summary: If an agent is also a customer and he closes an issue that he raised from within JIRA (NOT Customer Portal). If there is a comment added in the resolve issue screen, the issue closes and then re-opens. *Steps to reproduce* - Create an issue as an agent in SD - Assign the issue to yourself. - Resolve and close the issue. - Refresh the page. *Expected Result* Issue stays resolved based on selected resolution. *Actual Result* Issue gets resolved and gets re-opened immediately. *Cause* - The arrangement of the workflow post functions, places transitioning the issues in a higher position above add comment. (related to the order described [here|https://confluence.atlassian.com/display/JIRACLOUD/Advanced+workflow+configuration]. h3.Workaround - Edit the *Transition on comment* Automation Rule at -- {{https://<BASE_URL>.atlassian.net/servicedesk/agent/<PROJECT_ID>/settings/automation}} - Manually add in the following (See screenshot): {code} ELSE IF issue matches: Status = Resolved and "Customer Request Type" is not empty Comment is Public User is customer THEN Transition Issue Reopen Issue {code} |
Link |
New:
This issue relates to |
Labels | Original: affects-server | New: affects-cloud affects-server |
Labels | New: affects-server |
Workflow | Original: JSD Bug Workflow v2 [ 1602960 ] | New: JSD Bug Workflow v4 [ 1615791 ] |