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Suggestion
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Resolution: Unresolved
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None
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9
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1
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NOTE: This suggestion is for JIRA Service Desk Cloud. Using JIRA Service Desk Server? See the previously corresponding suggestion.
Summary
In Cloud, it's possible to retrieve attachments for a request via REST API albeit being experimental (requires HTTP header "X-ExperimentalApi":"opt-in"). Example:
- GET /rest/servicedeskapi/request/{issueIdOrKey}/attachment
- GET /rest/servicedeskapi/request/{issueIdOrKey}/comment/{commentId}/attachment
Reference: https://docs.atlassian.com/jira-servicedesk/REST/cloud/#servicedeskapi/request/ {issueIdOrKey}/attachment
However, the underlying redirection in comments to /secure/
{"thumbnail" or "attachment"}/
{commentId}/myimage.png?fromIssue=
{issueId}creates a problem for Connect Apps because Safari blocks cross-site cookies. This forces Apps to awkward and potentially unsafe proxies of the attachments.
Suggestion
Allow Jira to process attachment calls from API clients using the `ACT_AS_USER` mechanism to respect both user permissions and browser policies. And stabilize the APIs so the experimental header and label can be removed.
- is related to
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JSDSERVER-4952 REST API to retrieve attachments from requests
- Closed
- causes
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DEVHELP-5308 Failed to load
Form Name |
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Hello.
Rohan, the problem is not about don't be posible make the fetch of attachments but rather about the permission restriction for users of type customer.
Example of a link that needs login to see an attachament: https://mercadolibre.atlassian.net/servicedesk/customer/user/login?absolute=true&destination=%2Fplugins%2Fservlet%2Fservicedesk%2Fcustomershim%2Fsecure%2Fattachment%2F377918%2F377918_image-20210324-011506.png%3FfromIssue%3D1085671