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Bug
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Resolution: Fixed
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Low
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12
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Severity 3 - Minor
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1
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Summary
In New issue view single user-picker custom field does not apply the group filtering configured for the field.
Steps to Reproduce
- Create a single user picker custom field by accessing Jira Settings > Issues > Custom field > Add custom field.
- Add that custom field to a screen.
- Access that's custom field setting page and setup group/filter to a group with few users in it.
- Go to the project where that screen is placed and with the new issue view enabled, try to edit that custom field option.
Expected Results
The only users are shown are in the filter/group configured for the field.
Actual Results
All users are displayed.
Notes
The User picker custom field literally displays ALL users including Portal customers from Jira Service Desk.
Workaround (may not be applicable for some sites as we move to the new issue view)
- Disable the new issue view. For that follow the steps below:
- Select your avatar and choose Profile
- Turn off the New Jira issue view toggle under Labs
- is cloned from
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JRACLOUD-69303 New Issue View show disabled options of a custom field.
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- Closed
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- is related to
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ID-8128 Limit User Picker to members of certain groups/roles in System Fields in Jira Software, Jira Work Management, JIRA Service Management and Atlas
- Gathering Interest
- causes
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JST-488744 You do not have permission to view this issue
This is a needed functionality - we have been asked multiple times by our clients to implement user filtering on user single and multi-select types of fields.