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Bug
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Resolution: Duplicate
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Low
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None
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11
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Severity 3 - Minor
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Summary
This is not replicable on every instance.
In some cases, we cannot delete parent issues when they have sub-tasks with resolutions.
In the old issue view, Jira will show a successful message saying the ticket was deleted, but it's not. If you were previously on a page listing the issue, you may be redirected to it again and the issue may not be there, but refreshing the page reveals it. It still exists.
In the new issue view, you'll see this error:
We couldn't delete <issue key>
Check your connection, then give it another try.
Try again
Steps to Reproduce
- Create a project (has been tested with Kanban and business). Make sure it has a sub-task type
- Create a ticket and a sub-task to it
- Close the sub-task, adding a resolution to it
- Try to delete the parent
Expected Results
The parent is deleted
Actual Results
The behavior described above is seen. The tickets are not deleted.
If the parent had sub-tasks without resolution, some of these may have been deleted.
Note
The problem here is the sub-task preventing the parent from being deleted. We can delete the sub-task and we can delete the parent once the sub-task is deleted. What fails is deleting the parent while the sub-task is there.
In original testing, closed sub-task without resolution were also causing this, but with a different error in UI (same errors in logs). However, in recent testing, we could only replicate with sub-tasks with resolutions.
Workaround
Delete all sub-tasks with resolutions first.
- causes
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JRACLOUD-69642 Bulk delete throws generic error and stops if one of the issue is parent from a sub-task outside the search scope
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- Closed
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- duplicates
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JRACLOUD-71470 Some bulk operations that involve sub-tasks can fail with error 500
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- Closed
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