Uploaded image for project: 'Sourcetree for Windows'
  1. Sourcetree for Windows
  2. SRCTREEWIN-6512

Not working with Team Services (former Visual Studio Online) via SSH

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Verified (View Workflow)
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Last commented by user?:
      true
    • Symptom Severity:
      Minor

      Description

      I try to clone a repository from Team Services (former Visual Studio online), but I receive the following error:

      System.ComponentModel.Win32Exception: The system cannot find the file specified
      FATAL ERROR: Server sent disconnect message
      type 2 (protocol error)
      "Invalid packet"

      I'm using Putty, I double-checked - the correct SSH key is loaded. SSH access to my BitBucket account using the same key is working. Another Git application (GitExtensions) works with this key and this repository. I tried several repositories from different Team Services accounts and the same error appears on all of them.

        Attachments

        1. Screenshot_1.png
          Screenshot_1.png
          14 kB
        2. Screenshot_2.png
          Screenshot_2.png
          19 kB

          Issue Links

            Activity

              People

              • Votes:
                8 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Last commented:
                  1 year, 35 weeks, 4 days ago