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Bug
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Resolution: Unresolved
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Low
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None
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7.12.3, 8.0.1, 7.13.3
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7.12
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8
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Severity 3 - Minor
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0
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Summary
When REST PUT is made to change the request type of an issue that has a completely different workflow or field configuration is made, the result is a success. This shouldn't be the case as a change like this invalidates the workflow.
Steps to Reproduce
- Create two workflows with different status
- Associate issue type separately to the two workflows created above
- Create two Jira issue and set each request type to the workflows created earlier
- If you attempt to change the issue type from the UI, it won't be possible.
- If you attempt to change the issue type via REST api, the issue type is changed. This shouldn't be possible.
For Example:
PUT https://codebarrel.atlassian.net/rest/api/2/issue/SDD-17/
{ "fields": {"issuetype":{"id":10002}} }
Expected Results
An error should be returned that this is not possible.
Actual Results
A successful execution is returned.
Workaround
Currently none.
- causes
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JIRAAUTOSERVER-849 Changing Issue type in projects through automation does not change the underlying workflow in Database
- Gathering Impact
- is cloned from
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JRACLOUD-68207 Using REST API the issue type can be changed when workflows are completely different
- Closed