• Icon: Bug Bug
    • Resolution: Unresolved
    • Icon: Low Low
    • None
    • 4.18.0
    • Customer Portal

      Issue Summary

      When a new request is created on the CP the page loads and sometimes shows fewer SLAs than configured. After I refresh (say 5-10s later) all the configured SLAs are visible.

      Steps to Reproduce

      1. As a project admin configure several SLAs as viewable on the Customer Portal
      2. Log into the CP as a customer and raise a new request

      Expected Results

      • The CP displays the newly created request
      • All configured SLAs are displayed on the same page

      Actual Results

      Sometimes none, sometimes one, sometimes all (configured) SLAs are displayed.

      Cause

      This is because SLAs are calculated async to issue creation, so upon issue creation there is a chance that not all SLAs have been calculated for the new issue when the response is about to be composed.

      Workaround

      Refresh the request page

          Form Name

            [JSDSERVER-8353] Not all SLAs are visible on the Customer Portal after request creation

            Marc Dacanay made changes -
            Labels New: ril
            Marc Dacanay made changes -
            Remote Link New: This issue links to "Internal ticket (Web Link)" [ 955281 ]
            Benjamin Suess made changes -
            Status Original: Short Term Backlog [ 12074 ] New: Gathering Impact [ 12072 ]
            Benjamin Suess made changes -
            Status Original: Long Term Backlog [ 12073 ] New: Short Term Backlog [ 12074 ]
            Alex Cooksey made changes -
            Status Original: Short Term Backlog [ 12074 ] New: Long Term Backlog [ 12073 ]
            Bugfix Automation Bot made changes -
            Support reference count New: 1
            Sam Nazha (Inactive) made changes -
            Description Original: h3. Issue Summary

            When a new request is created on the CP the page loads and sometimes shows fewer SLAs than configured. After I refresh (say 5-10s later) all the configured SLAs are visible.
            h3. Steps to Reproduce
             # As a project admin configure several SLAs as viewable on the Customer Portal
             # Log into the CP as a customer and raise a new request

            h3. Expected Results
             * The CP displays the newly created request
             * All configured SLAs are displayed on the same page

            h3. Actual Results

            Sometimes none, sometimes one, sometimes all (configured) SLAs are displayed.
            {noformat}
            ...
            {noformat}
            h3. Workaround

            Refresh the request page
            New: h3. Issue Summary

            When a new request is created on the CP the page loads and sometimes shows fewer SLAs than configured. After I refresh (say 5-10s later) all the configured SLAs are visible.
            h3. Steps to Reproduce
             # As a project admin configure several SLAs as viewable on the Customer Portal
             # Log into the CP as a customer and raise a new request

            h3. Expected Results
             * The CP displays the newly created request
             * All configured SLAs are displayed on the same page

            h3. Actual Results

            Sometimes none, sometimes one, sometimes all (configured) SLAs are displayed.
            h3. Cause

            This is because SLAs are calculated async to issue creation, so upon issue creation there is a chance that not all SLAs have been calculated for the new issue when the response is about to be composed.
            h3. Workaround

            Refresh the request page
            Sam Nazha (Inactive) made changes -
            Status Original: Long Term Backlog [ 12073 ] New: Short Term Backlog [ 12074 ]
            Sam Nazha (Inactive) made changes -
            Status Original: Needs Triage [ 10030 ] New: Long Term Backlog [ 12073 ]
            Sam Nazha (Inactive) made changes -
            Link New: This issue is caused by JSDSERVER-325 [ JSDSERVER-325 ]
            Sam Nazha (Inactive) created issue -

              Unassigned Unassigned
              d451e9482136 Sam Nazha (Inactive)
              Affected customers:
              1 This affects my team
              Watchers:
              1 Start watching this issue

                Created:
                Updated: