Uploaded image for project: 'Jira Service Management Data Center'
  1. Jira Service Management Data Center
  2. JSDSERVER-8353

Not all SLAs are visible on the Customer Portal after request creation

    XMLWordPrintable

Details

    • Bug
    • Resolution: Unresolved
    • Low
    • None
    • 4.18.0
    • Customer Portal
    • None

    Description

      Issue Summary

      When a new request is created on the CP the page loads and sometimes shows fewer SLAs than configured. After I refresh (say 5-10s later) all the configured SLAs are visible.

      Steps to Reproduce

      1. As a project admin configure several SLAs as viewable on the Customer Portal
      2. Log into the CP as a customer and raise a new request

      Expected Results

      • The CP displays the newly created request
      • All configured SLAs are displayed on the same page

      Actual Results

      Sometimes none, sometimes one, sometimes all (configured) SLAs are displayed.

      Cause

      This is because SLAs are calculated async to issue creation, so upon issue creation there is a chance that not all SLAs have been calculated for the new issue when the response is about to be composed.

      Workaround

      Refresh the request page

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              d451e9482136 Sam Nazha
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:

                Backbone Issue Sync