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Bug
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Resolution: Unresolved
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Low
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None
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4.18.0
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1
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Severity 3 - Minor
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Issue Summary
When a new request is created on the CP the page loads and sometimes shows fewer SLAs than configured. After I refresh (say 5-10s later) all the configured SLAs are visible.
Steps to Reproduce
- As a project admin configure several SLAs as viewable on the Customer Portal
- Log into the CP as a customer and raise a new request
Expected Results
- The CP displays the newly created request
- All configured SLAs are displayed on the same page
Actual Results
Sometimes none, sometimes one, sometimes all (configured) SLAs are displayed.
Cause
This is because SLAs are calculated async to issue creation, so upon issue creation there is a chance that not all SLAs have been calculated for the new issue when the response is about to be composed.
Workaround
Refresh the request page
- is caused by
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JSDSERVER-325 Allow SLA to be viewed from Customer Portal
- Closed
- links to
Form Name |
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[JSDSERVER-8353] Not all SLAs are visible on the Customer Portal after request creation
Labels | New: ril |
Remote Link | New: This issue links to "Internal ticket (Web Link)" [ 955281 ] |
Status | Original: Short Term Backlog [ 12074 ] | New: Gathering Impact [ 12072 ] |
Status | Original: Long Term Backlog [ 12073 ] | New: Short Term Backlog [ 12074 ] |
Status | Original: Short Term Backlog [ 12074 ] | New: Long Term Backlog [ 12073 ] |
Support reference count | New: 1 |
Description |
Original:
h3. Issue Summary
When a new request is created on the CP the page loads and sometimes shows fewer SLAs than configured. After I refresh (say 5-10s later) all the configured SLAs are visible. h3. Steps to Reproduce # As a project admin configure several SLAs as viewable on the Customer Portal # Log into the CP as a customer and raise a new request h3. Expected Results * The CP displays the newly created request * All configured SLAs are displayed on the same page h3. Actual Results Sometimes none, sometimes one, sometimes all (configured) SLAs are displayed. {noformat} ... {noformat} h3. Workaround Refresh the request page |
New:
h3. Issue Summary
When a new request is created on the CP the page loads and sometimes shows fewer SLAs than configured. After I refresh (say 5-10s later) all the configured SLAs are visible. h3. Steps to Reproduce # As a project admin configure several SLAs as viewable on the Customer Portal # Log into the CP as a customer and raise a new request h3. Expected Results * The CP displays the newly created request * All configured SLAs are displayed on the same page h3. Actual Results Sometimes none, sometimes one, sometimes all (configured) SLAs are displayed. h3. Cause This is because SLAs are calculated async to issue creation, so upon issue creation there is a chance that not all SLAs have been calculated for the new issue when the response is about to be composed. h3. Workaround Refresh the request page |
Status | Original: Long Term Backlog [ 12073 ] | New: Short Term Backlog [ 12074 ] |
Status | Original: Needs Triage [ 10030 ] | New: Long Term Backlog [ 12073 ] |
Link |
New:
This issue is caused by |