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  1. Jira Service Management Data Center
  2. JSDSERVER-5847

Query DSL provider plugin is not always being updated when Service Desk is updated

      Summary

      query dsl provider plugin is not always being updated when Service Desk is updated

      Environment

      Still trying to determine what environmental aspects might factor in here

      Steps to Reproduce

      1. Have an existing work Jira Service Desk (say a 3.7 or 3.8 version)
      2. Upgrade Jira/Service Desk to a more recent version, such as 7.9.2/3.12.2 or 7.10.0/3.13.0

      Expected Results

      Service Desk Queues should be functional after the upgrade

      Actual Results

      Queues are not working.
      Logs show error messages like this:

      2018-06-06 10:10:20,107 http-nio-1081-exec-10 ERROR <username> 610x154x1 192r6a6 (null),<user-ip>,127.0.0.1 /rest/servicedesk/1/servicedesk/<projectname>/queues [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: com.querydsl.sql.dml.SQLInsertClause.getBatchCount()I
      java.lang.NoSuchMethodError: com.querydsl.sql.dml.SQLInsertClause.getBatchCount()I
       at com.atlassian.servicedesk.internal.feature.queue.QueueStore.addColumns(QueueStore.java:218)
       at com.atlassian.servicedesk.internal.feature.queue.QueueStore.addQueue(QueueStore.java:111)
       at com.atlassian.servicedesk.internal.feature.queue.QueueManagerImpl.lambda$null$4(QueueManagerImpl.java:80)
       at io.atlassian.fugue.Either$RightProjection.map(Either.java:872)
       at io.atlassian.fugue.Either.map(Either.java:217)
      ...
      

      Other variants include:

      "com.querydsl.sql.dml.SQLUpdateClause.getBatchCount () I"

      Cause

      The Query dsl provider plugin is not always installed in the correct needed version after the upgrade.
      ie. SD 3.13 needs the plugin version 4.1.4, but sometimes only 4.0.7 is available.

      Workaround

      We can manually update this query dsl plugin to a newer version to fix this:

      1. Download the querydsl 4.1.4 plugin jar file in this link: querydsl-4.1.4-provider-plugin-1.0.jar
      2. Stop JIRA
      3. Remove the querydsl jar file that is located in the directory $JIRA_HOME/plugins/installed-plugins/ (the file name should be similar to querydsl-4.0.7-provider-plugin-1.1)
      4. Copy the downloaded file into this same /installed-plugins/ folder
      5. Start JIRA

      Notes

      This problem does not happen for all upgrades. Only some customers have found this plugin is not updating in their system.

          Form Name

            [JSDSERVER-5847] Query DSL provider plugin is not always being updated when Service Desk is updated

            Daniel C Berlin (Inactive) added a comment - https://getsupport.atlassian.com/browse/PSSRV-9170

            This seems to happen pretty predictably on systems it happens on. Both our dev and production instances ran into this issue. We thought perhaps it was related to activity/automation that occurs on production but the dev instance is non accessible.

             

            We did note that querydsl was under user managed addons when it was on the incompatible version where as it becomes a system addon once again when updating to the proper version. So it could be that if you updated to just the right version it was user managed vs system managed?

             

            Either way, this resolved the issue for us as well.

            Xaviar Steavenson added a comment - This seems to happen pretty predictably on systems it happens on. Both our dev and production instances ran into this issue. We thought perhaps it was related to activity/automation that occurs on production but the dev instance is non accessible.   We did note that querydsl was under user managed addons when it was on the incompatible version where as it becomes a system addon once again when updating to the proper version. So it could be that if you updated to just the right version it was user managed vs system managed?   Either way, this resolved the issue for us as well.

            The workaround is working on our end. Thanks for providing the details!

            Erik Thomas added a comment - The workaround is working on our end. Thanks for providing the details!

            Problem encountered on JSW 7.10.0 & 7.10.1 and JSD 3.13.0 and 3.13.1

             

            Nigel Budd (CV) added a comment - Problem encountered on JSW 7.10.0 & 7.10.1 and JSD 3.13.0 and 3.13.1  

            Rene C. [Atlassian Support] added a comment - https://getsupport.atlassian.com/browse/JSP-405007#

              szaporozhtsev Sergey Zaporozhtsev (Inactive)
              aheinzer Andy Heinzer
              Affected customers:
              35 This affects my team
              Watchers:
              42 Start watching this issue

                Created:
                Updated:
                Resolved: