Summary
query dsl provider plugin is not always being updated when Service Desk is updated
Environment
Still trying to determine what environmental aspects might factor in here
Steps to Reproduce
- Have an existing work Jira Service Desk (say a 3.7 or 3.8 version)
- Upgrade Jira/Service Desk to a more recent version, such as 7.9.2/3.12.2 or 7.10.0/3.13.0
Expected Results
Service Desk Queues should be functional after the upgrade
Actual Results
Queues are not working.
Logs show error messages like this:
2018-06-06 10:10:20,107 http-nio-1081-exec-10 ERROR <username> 610x154x1 192r6a6 (null),<user-ip>,127.0.0.1 /rest/servicedesk/1/servicedesk/<projectname>/queues [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: com.querydsl.sql.dml.SQLInsertClause.getBatchCount()I
java.lang.NoSuchMethodError: com.querydsl.sql.dml.SQLInsertClause.getBatchCount()I
at com.atlassian.servicedesk.internal.feature.queue.QueueStore.addColumns(QueueStore.java:218)
at com.atlassian.servicedesk.internal.feature.queue.QueueStore.addQueue(QueueStore.java:111)
at com.atlassian.servicedesk.internal.feature.queue.QueueManagerImpl.lambda$null$4(QueueManagerImpl.java:80)
at io.atlassian.fugue.Either$RightProjection.map(Either.java:872)
at io.atlassian.fugue.Either.map(Either.java:217)
...
Other variants include:
"com.querydsl.sql.dml.SQLUpdateClause.getBatchCount () I"
Cause
The Query dsl provider plugin is not always installed in the correct needed version after the upgrade.
ie. SD 3.13 needs the plugin version 4.1.4, but sometimes only 4.0.7 is available.
Workaround
We can manually update this query dsl plugin to a newer version to fix this:
- Download the querydsl 4.1.4 plugin jar file in this link: querydsl-4.1.4-provider-plugin-1.0.jar

- Stop JIRA
- Remove the querydsl jar file that is located in the directory $JIRA_HOME/plugins/installed-plugins/ (the file name should be similar to querydsl-4.0.7-provider-plugin-1.1)
- Copy the downloaded file into this same /installed-plugins/ folder
- Start JIRA
Notes
This problem does not happen for all upgrades. Only some customers have found this plugin is not updating in their system.
https://getsupport.atlassian.com/browse/PSSRV-9170