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  1. Jira Service Management Data Center
  2. JSDSERVER-5667

Service Desk Queues appear blank and Customer Portal seems broken when using a Windows based reverse proxy

      Summary

      Service Desk Queues appear blank when using a Windows based reverse proxy

      Environment

      • Jira site is being served up via a windows based reverse proxy, such as IIS

      Steps to Reproduce

      1. Install Jira Service Desk 3.9.0
      2. Setup a Windows Reverse proxy for Jira to use such as the steps in Integrating JIRA applications with IIS - Atlassian Documentation
      3. Login as a Jira Admin, that also has application access to JSD (ie you are an Agent)
      4. create a new Jira service Desk project (using a sample project with sample data works)
      5. Visit that project's queues

      Expected Results

      Should be able to see those queues

      Actual Results

      The queue appears blank.
      Also when generating a HAR file we can see HTTP 400 errors (Bad Request) for a pair of resources

      https://wwwxxx.example.com/jira/s/829f1542a00a3b316cce28d94773a099-T/-ti4mc6/76002/ca607ec8b51d3f1fd5e6542230b47050/17de11d790a504112fc0738e9f7d40d9/_/download/contextbatch/js/jira.rich.editor,sd.project.queues,jira.view.issue,com.atlassian.jira.plugins.jira-development-integration-plugin:devstatus-dialog-resources-ctx,-_super,-jira.view.issue,-jira.global,-sd.project.api,-atl.general,-sd.project.sidebar.content,-sd.project.view,-jira.project.sidebar,-com.atlassian.jira.projects.sidebar.init,-jira.general,-browser-metrics-plugin.contrib/batch.js?agile_global_admin_condition=true&healthcheck-resources=true&is-server-instance=true&is-system-admin=true&jag=true&jaguser=true&jira.create.linked.issue=true&locale=de-DE&nps-acknowledged=true&nps-not-opted-out=true&richediton=true&sd_operational=true&user-logged-in=true
      

      AND

      https://wwwxxx.example.com/jira/s/22d5ee8ada865cc1e0c56d07dbe3d9de-T/-ti4mc6/76002/ca607ec8b51d3f1fd5e6542230b47050/17de11d790a504112fc0738e9f7d40d9/_/download/contextbatch/css/jira.rich.editor,sd.project.queues,jira.view.issue,com.atlassian.jira.plugins.jira-development-integration-plugin:devstatus-dialog-resources-ctx,-_super,-jira.view.issue,-jira.global,-sd.project.api,-atl.general,-sd.project.sidebar.content,-sd.project.view,-jira.project.sidebar,-com.atlassian.jira.projects.sidebar.init,-jira.general,-browser-metrics-plugin.contrib/batch.css?agile_global_admin_condition=true&healthcheck-resources=true&is-server-instance=true&is-system-admin=true&jag=true&jaguser=true&jira.create.linked.issue=true&nps-acknowledged=true&nps-not-opted-out=true&richediton=true&sd_operational=true&user-logged-in=true 
      

      The first request has URL length of 823 characters, while the second that also failed has 812 characters. There were many other shorter URLs that loaded in the page correctly.

      You will notice that both requests are calling on the element called 'sd.project.queues'.

      Notes

      This problem appears to be similar in nature to that of https://jira.atlassian.com/browse/JRASERVER-64917
      While that bug ticket was in regards to the way issue linking in Jira can cause this problem in the same kind of environment, it appears that the way Service Desk is constructing URLs could also encounter this problem in some customers environments.

      Luckily, the work-around on that bug ticket can also be applied here:

      Cause

      Due to the URL length increase, we are reaching the Windows Path Limit of 260 characters. This not the IIS URL limit. More details here:

      Workaround

      From the above articles, it is possible to modify the Windows Registry and increase the UrlSegmentMaxLength value to handle more characters:

      1. Backup the Registry
      2. With Regedit, browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP\Parameters
      3. Find the value for UrlSegmentMaxLength (or if it doesn't exist add a DWORD value), and change it to 00001000 (this is the hex for 4096)

      Powershell alternative:

      Set-ItemProperty -Path HKLM:\System\CurrentControlSet\Services\HTTP\Parameters -Name UrlSegmentMaxLength -Value 4096
      

      After using either method to adjust the registry (Regedit or Powershell), you must restart Windows for the changes to take effect. This will necessitate downtime, please plan a maintenance window accordingly.

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            IMPORTANT: JAC is a Public system and anyone on the internet will be able to view the data in the created JAC tickets. Please don’t include Customer or Sensitive data in the JAC ticket.
            Uploaded image for project: 'Jira Service Management Data Center'
            1. Jira Service Management Data Center
            2. JSDSERVER-5667

            Service Desk Queues appear blank and Customer Portal seems broken when using a Windows based reverse proxy

                Summary

                Service Desk Queues appear blank when using a Windows based reverse proxy

                Environment

                • Jira site is being served up via a windows based reverse proxy, such as IIS

                Steps to Reproduce

                1. Install Jira Service Desk 3.9.0
                2. Setup a Windows Reverse proxy for Jira to use such as the steps in Integrating JIRA applications with IIS - Atlassian Documentation
                3. Login as a Jira Admin, that also has application access to JSD (ie you are an Agent)
                4. create a new Jira service Desk project (using a sample project with sample data works)
                5. Visit that project's queues

                Expected Results

                Should be able to see those queues

                Actual Results

                The queue appears blank.
                Also when generating a HAR file we can see HTTP 400 errors (Bad Request) for a pair of resources

                https://wwwxxx.example.com/jira/s/829f1542a00a3b316cce28d94773a099-T/-ti4mc6/76002/ca607ec8b51d3f1fd5e6542230b47050/17de11d790a504112fc0738e9f7d40d9/_/download/contextbatch/js/jira.rich.editor,sd.project.queues,jira.view.issue,com.atlassian.jira.plugins.jira-development-integration-plugin:devstatus-dialog-resources-ctx,-_super,-jira.view.issue,-jira.global,-sd.project.api,-atl.general,-sd.project.sidebar.content,-sd.project.view,-jira.project.sidebar,-com.atlassian.jira.projects.sidebar.init,-jira.general,-browser-metrics-plugin.contrib/batch.js?agile_global_admin_condition=true&healthcheck-resources=true&is-server-instance=true&is-system-admin=true&jag=true&jaguser=true&jira.create.linked.issue=true&locale=de-DE&nps-acknowledged=true&nps-not-opted-out=true&richediton=true&sd_operational=true&user-logged-in=true
                

                AND

                https://wwwxxx.example.com/jira/s/22d5ee8ada865cc1e0c56d07dbe3d9de-T/-ti4mc6/76002/ca607ec8b51d3f1fd5e6542230b47050/17de11d790a504112fc0738e9f7d40d9/_/download/contextbatch/css/jira.rich.editor,sd.project.queues,jira.view.issue,com.atlassian.jira.plugins.jira-development-integration-plugin:devstatus-dialog-resources-ctx,-_super,-jira.view.issue,-jira.global,-sd.project.api,-atl.general,-sd.project.sidebar.content,-sd.project.view,-jira.project.sidebar,-com.atlassian.jira.projects.sidebar.init,-jira.general,-browser-metrics-plugin.contrib/batch.css?agile_global_admin_condition=true&healthcheck-resources=true&is-server-instance=true&is-system-admin=true&jag=true&jaguser=true&jira.create.linked.issue=true&nps-acknowledged=true&nps-not-opted-out=true&richediton=true&sd_operational=true&user-logged-in=true 
                

                The first request has URL length of 823 characters, while the second that also failed has 812 characters. There were many other shorter URLs that loaded in the page correctly.

                You will notice that both requests are calling on the element called 'sd.project.queues'.

                Notes

                This problem appears to be similar in nature to that of https://jira.atlassian.com/browse/JRASERVER-64917
                While that bug ticket was in regards to the way issue linking in Jira can cause this problem in the same kind of environment, it appears that the way Service Desk is constructing URLs could also encounter this problem in some customers environments.

                Luckily, the work-around on that bug ticket can also be applied here:

                Cause

                Due to the URL length increase, we are reaching the Windows Path Limit of 260 characters. This not the IIS URL limit. More details here:

                Workaround

                From the above articles, it is possible to modify the Windows Registry and increase the UrlSegmentMaxLength value to handle more characters:

                1. Backup the Registry
                2. With Regedit, browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP\Parameters
                3. Find the value for UrlSegmentMaxLength (or if it doesn't exist add a DWORD value), and change it to 00001000 (this is the hex for 4096)

                Powershell alternative:

                Set-ItemProperty -Path HKLM:\System\CurrentControlSet\Services\HTTP\Parameters -Name UrlSegmentMaxLength -Value 4096
                

                After using either method to adjust the registry (Regedit or Powershell), you must restart Windows for the changes to take effect. This will necessitate downtime, please plan a maintenance window accordingly.

                        Unassigned Unassigned
                        aheinzer Andy Heinzer
                        Votes:
                        2 Vote for this issue
                        Watchers:
                        11 Start watching this issue

                          Created:
                          Updated:
                          Resolved:

                              Unassigned Unassigned
                              aheinzer Andy Heinzer
                              Affected customers:
                              2 This affects my team
                              Watchers:
                              11 Start watching this issue

                                Created:
                                Updated:
                                Resolved: