Uploaded image for project: 'Jira Service Management Data Center'
  1. Jira Service Management Data Center
  2. JSDSERVER-5364

Notifications are not sent to Reporters and Request Participants until an application restart

    • Icon: Bug Bug
    • Resolution: Fixed
    • Icon: Low Low
    • 3.7.1, 3.8.2
    • 3.4.2, 3.5.0, 3.5.2, 3.6.0, 3.6.1, 3.6.4
    • Customer Notification
    • None

      Problem definition

      No customer notifications are sent to Reporters and Request Participants.

      Steps to reproduce the issue

      N/A

      Diagnosis

      • JIRA notifications are sent as usual, only Service Desk notifications that are not sending.
      • Mail queue and error queue are empty.
      • No errors or exceptions in the logs indicating that the emails could not be sent.
      • New entries in the AO_4E8AE6_NOTIF_BATCH_QUEUE database tables have no SENT_TIME, which means that the notifications are queued but not getting sent.

      Workaround

      Restart JIRA

            [JSDSERVER-5364] Notifications are not sent to Reporters and Request Participants until an application restart

            Meriem Dhahak made changes -
            Remote Link New: This issue links to "Page (Confluence)" [ 673355 ]
            Julien Rey made changes -
            Remote Link Original: This issue links to "Page (Confluence)" [ 415768 ]
            Julien Rey made changes -
            Remote Link New: This issue links to "Page (Confluence)" [ 496835 ]
            Owen made changes -
            Workflow Original: JSD Bug Workflow v5 - TEMP [ 2431141 ] New: JAC Bug Workflow v3 [ 3126633 ]
            Status Original: Done [ 10044 ] New: Closed [ 6 ]
            Julien Rey made changes -
            Remote Link New: This issue links to "Page (Confluence)" [ 415694 ]
            Julien Rey made changes -
            Remote Link New: This issue links to "Page (Confluence)" [ 415768 ]

            We encountered this issue again in JSD 3.9.8. 

            René Bodack added a comment - We encountered this issue again in JSD 3.9.8. 
            Owen made changes -
            Symptom Severity Original: Critical [ 14430 ] New: Severity 1 - Critical [ 15830 ]
            Jeremy Sanchez made changes -
            Affects Version/s New: 3.5.2 [ 75207 ]

            Hi,

            We have installed the 3.6.1 and we noticed that this issue is related with the one described in JRASERVER-64325. It occurs whenever the Job ID for sd.custom.notification.batch.send is duplicated. To fix this issue, we understand that both bugs affecting JSD and Jira Platform (JSRV) should be resolved. We plan on upgrading JSD to 3.8.2. This version corresponds to JSRV 7.5.1 and this version does not resolve the bug of duplicated Job ID. What should we do in this case? 

            Best regards.

            Sanaa Marmar added a comment - Hi, We have installed the 3.6.1 and we noticed that this issue is related with the one described in  JRASERVER-64325 . It occurs whenever the Job ID for sd.custom.notification.batch.send is duplicated. To fix this issue, we understand that both bugs affecting JSD and Jira Platform (JSRV) should be resolved. We plan on upgrading JSD to 3.8.2. This version corresponds to JSRV 7.5.1 and this version does not resolve the bug of duplicated Job ID. What should we do in this case?  Best regards.

              ashubovych moofoo (Inactive)
              michin Michelle Chin
              Affected customers:
              4 This affects my team
              Watchers:
              18 Start watching this issue

                Created:
                Updated:
                Resolved: