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  1. Jira Service Management Data Center
  2. JSDSERVER-5364

Notifications are not sent to Reporters and Request Participants until an application restart

    • Icon: Bug Bug
    • Resolution: Fixed
    • Icon: Low Low
    • 3.7.1, 3.8.2
    • 3.4.2, 3.5.0, 3.5.2, 3.6.0, 3.6.1, 3.6.4
    • Customer Notification
    • None

      Problem definition

      No customer notifications are sent to Reporters and Request Participants.

      Steps to reproduce the issue

      N/A

      Diagnosis

      • JIRA notifications are sent as usual, only Service Desk notifications that are not sending.
      • Mail queue and error queue are empty.
      • No errors or exceptions in the logs indicating that the emails could not be sent.
      • New entries in the AO_4E8AE6_NOTIF_BATCH_QUEUE database tables have no SENT_TIME, which means that the notifications are queued but not getting sent.

      Workaround

      Restart JIRA

            [JSDSERVER-5364] Notifications are not sent to Reporters and Request Participants until an application restart

            We encountered this issue again in JSD 3.9.8. 

            René Bodack added a comment - We encountered this issue again in JSD 3.9.8. 

            Hi,

            We have installed the 3.6.1 and we noticed that this issue is related with the one described in JRASERVER-64325. It occurs whenever the Job ID for sd.custom.notification.batch.send is duplicated. To fix this issue, we understand that both bugs affecting JSD and Jira Platform (JSRV) should be resolved. We plan on upgrading JSD to 3.8.2. This version corresponds to JSRV 7.5.1 and this version does not resolve the bug of duplicated Job ID. What should we do in this case? 

            Best regards.

            Sanaa Marmar added a comment - Hi, We have installed the 3.6.1 and we noticed that this issue is related with the one described in  JRASERVER-64325 . It occurs whenever the Job ID for sd.custom.notification.batch.send is duplicated. To fix this issue, we understand that both bugs affecting JSD and Jira Platform (JSRV) should be resolved. We plan on upgrading JSD to 3.8.2. This version corresponds to JSRV 7.5.1 and this version does not resolve the bug of duplicated Job ID. What should we do in this case?  Best regards.

            Thanks for the update Michelle.

            I believe the issue we see is quit different then.

            The issue affects a single user and from analysis, only in this one issue(hence all other users get notified in this issue and the user in question gets notified in other issues).

            We worked around this via emails as we could not explain why the problem occurs.

            Thanks.

            Ismael

            Ismael Jimoh added a comment - Thanks for the update Michelle. I believe the issue we see is quit different then. The issue affects a single user and from analysis, only in this one issue(hence all other users get notified in this issue and the user in question gets notified in other issues). We worked around this via emails as we could not explain why the problem occurs. Thanks. Ismael

            servicedesk67 my apologies for this very much delayed reply. The bug happens randomly, we have not been able to reproduce this issue reliably at the moment.

            ismael.jimoh it only affects Service Desk notifications. That being said, if an Agent is the Reporter of a Service Desk request and the global setting to send customers both Jira and Service Desk notifications is disabled, the Agent will not be notified for that particular issue, same goes to other customers involved in that ticket.

            Michelle Chin added a comment - servicedesk67 my apologies for this very much delayed reply. The bug happens randomly, we have not been able to reproduce this issue reliably at the moment. ismael.jimoh it only affects Service Desk notifications. That being said, if an Agent is the Reporter of a Service Desk request and the global setting to send customers both Jira and Service Desk notifications is disabled , the Agent will not be notified for that particular issue, same goes to other customers involved in that ticket.

            Hi Michelle,

            May I know if this impacts all users when it fails or agents get notified while other users do not.

            Thanks.

            Ismael

            Ismael Jimoh added a comment - Hi Michelle, May I know if this impacts all users when it fails or agents get notified while other users do not. Thanks. Ismael

            Box IT added a comment -

            Hello Michelle, 

            Do you have any information on how frequently this bug occurs, or whether there is a trigger for it? Is it intermittent and recurring, or does this just happen once immediately after upgrading to 3.6.x ? 

            Box IT added a comment - Hello Michelle,  Do you have any information on how frequently this bug occurs, or whether there is a trigger for it? Is it intermittent and recurring, or does this just happen once immediately after upgrading to 3.6.x ? 

              ashubovych moofoo (Inactive)
              michin Michelle Chin
              Affected customers:
              4 This affects my team
              Watchers:
              18 Start watching this issue

                Created:
                Updated:
                Resolved: