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  1. Jira Service Management Data Center
  2. JSDSERVER-486

Comment can't be added for Service Desk Customers via email due to lack of Add Comment permission by default

    • Icon: Bug Bug
    • Resolution: Obsolete
    • Icon: Low Low
    • None
    • 1.2.5, 1.2.6.1
    • Email - Incoming

      Steps to Reproduce

      1. Create a user with valid email
      2. Create a Service Desk with administrator
      3. Go to the People tab and remove jira-users from the Service Desk Team
      4. Login as the user(Service Desk Customer)
      5. File a Service Desk request
      6. When you receive the notification as the Service Desk Customer, reply directly to the notification with any comment

      Expected Behaviour:

      Mail handler should process that email and comment in that issue

      Actual Behaviour:

      Comment not added for the Service Desk customer

      In Debug incoming log:

      2014-04-25 23:28:03,542 DEBUG [testing] QuartzScheduler_Worker-0 ServiceRunner    mail capture S: +OK message follows
      2014-04-25 23:28:03,715 DEBUG [testing] QuartzScheduler_Worker-0 ServiceRunner    mail capture User 'vicky' does not have permission to comment on an issue in project '10200'.
      2014-04-25 23:28:03,717 DEBUG [testing] QuartzScheduler_Worker-0 ServiceRunner    mail capture Deleting Message: <CABuj-xkVgBSwF5PGN9L9VVBBwgnktmYEyMbiUgA_h9Nq9dMTMQ@mail.gmail.com>
      2014-04-25 23:28:03,717 DEBUG [testing] QuartzScheduler_Worker-0 ServiceRunner    mail capture Closing folder
      2014-04-25 23:28:03,741 DEBUG [testing] QuartzScheduler_Worker-0 ServiceRunner    mail capture Delivered-To: tecken90@gmail.com
      

      Root Cause:

      Default Service Desk permission didn't add Service Desk Customer to the Add Comment permission in the permission scheme.

      Workaround:

      Add Service Desk Customer into the Add Comment permission in the project's permission scheme

          Form Name

            [JSDSERVER-486] Comment can't be added for Service Desk Customers via email due to lack of Add Comment permission by default

            Owen made changes -
            Workflow Original: JSD Bug Workflow v5 - TEMP [ 2304811 ] New: JAC Bug Workflow v3 [ 3125120 ]
            Status Original: Done [ 10044 ] New: Closed [ 6 ]
            Katherine Yabut made changes -
            Workflow Original: JSD Bug Workflow v5 [ 2059379 ] New: JSD Bug Workflow v5 - TEMP [ 2304811 ]
            Katherine Yabut made changes -
            Workflow Original: JSD Bug Workflow v5 - TEMP [ 2056813 ] New: JSD Bug Workflow v5 [ 2059379 ]
            Katherine Yabut made changes -
            Workflow Original: JSD Bug Workflow v5 [ 1955465 ] New: JSD Bug Workflow v5 - TEMP [ 2056813 ]
            Katherine Yabut made changes -
            Workflow Original: JSD Bug Workflow v4 [ 1615432 ] New: JSD Bug Workflow v5 [ 1955465 ]
            Confluence Escalation Bot (Inactive) made changes -
            Labels New: affects-server
            Katherine Yabut made changes -
            Workflow Original: JSD Bug Workflow v2 [ 1602112 ] New: JSD Bug Workflow v4 [ 1615432 ]
            Owen made changes -
            Workflow Original: JSD Bug Workflow [ 1399211 ] New: JSD Bug Workflow v2 [ 1602112 ]
            Marty (Inactive) made changes -
            Component/s New: Email - Incoming [ 32490 ]
            Owen Sanico [Administrative Account] made changes -
            Workflow Original: TTT: Simple Issue Tracking Workflow [ 682333 ] New: JSD Bug Workflow [ 1399211 ]

              Unassigned Unassigned
              yen@atlassian.com TeckEn (Inactive)
              Affected customers:
              4 This affects my team
              Watchers:
              6 Start watching this issue

                Created:
                Updated:
                Resolved: