Attachment in non-multipart email will not be attached to the request created

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    • Severity 3 - Minor
    • 2

      Problem Statement

      Emails with content-type other than Multipart will be created as a new request, however if the email contains an attachment it will not be added to the request

      Steps to Reproduce the Problem

      1. Send an email to Service Desk project with content-type below. For example, the voicemail notification through email from Cisco Unity Connection
         Content-Type: audio/wav; name=VoiceMessage.wav
         Content-Transfer-Encoding: Base64
         Content-Disposition: inline; filename=VoiceMessage.wav; voice=Voice-Message
         
      2. The request will be created without the .wav file attached.

      Cause

      The mail handler has not been designed to handle non-multipart email properly.

      Workaround

      Try forwarding the email, a request will be created with the .wav file added as an attachment in the comment.
      The forwarded email will have Content-Type: multipart/mixed or Content-Type: multipart/alternative in the email header

            Assignee:
            Matthew McMahon (Inactive)
            Reporter:
            Michelle Chin (Inactive)
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              Created:
              Updated:
              Resolved: