Details
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Bug
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Resolution: Fixed
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Low
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3.1.2, 3.1.9
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Severity 3 - Minor
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2
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Description
Problem Statement
Emails with content-type other than Multipart will be created as a new request, however if the email contains an attachment it will not be added to the request
Steps to Reproduce the Problem
- Send an email to Service Desk project with content-type below. For example, the voicemail notification through email from Cisco Unity Connection
Content-Type: audio/wav; name=VoiceMessage.wav Content-Transfer-Encoding: Base64 Content-Disposition: inline; filename=VoiceMessage.wav; voice=Voice-Message
- The request will be created without the .wav file attached.
Cause
The mail handler has not been designed to handle non-multipart email properly.
Workaround
Try forwarding the email, a request will be created with the .wav file added as an attachment in the comment.
The forwarded email will have Content-Type: multipart/mixed or Content-Type: multipart/alternative in the email header
Attachments
Issue Links
- relates to
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JRASERVER-34276 Mail handler is not able to pick up the attachment
- Closed
- is related to
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DESK-4969 Loading...