Uploaded image for project: 'Jira Service Management Data Center'
  1. Jira Service Management Data Center
  2. JSDSERVER-4220

JIRA becomes inacessible after upgrading JIRA Service Desk to 3.2.0.

      Summary

      JIRA becomes inacessible after upgrading JIRA Service Desk to 3.2.0.

      Environment

      • PostgreSQL 9.3

      Steps to Reproduce

      1. Install JIRA 7.0.10 or 7.1.9
      2. Install JIRA Service Desk 3.0.10 or 3.1.9
      3. Upgrade JIRA to 7.2.0
      4. Navigate to Cog Icon > Applications > Upgrade JIRA Service Desk to 3.2.0
      5. Navigate to any other page in JIRA.

      Expected Results

      JIRA should be accessible after the upgrade.

      Actual Results

      JIRA becomes inacessible, showing a 500 error with the following stack trace:

      Technical details
      Log's referral number: 1949e8c6-a651-4a17-8ab8-d8f1b3666a10
      Cause
      Referer URL: http://localhost:8080/plugins/servlet/applications/versions-licenses
      java.lang.RuntimeException: javax.servlet.ServletException: java.lang.IllegalArgumentException: Root page 'com.atlassian.jira.gadgets:dashboard-page' does not exist!
      java.lang.RuntimeException: javax.servlet.ServletException: java.lang.IllegalArgumentException: Root page 'com.atlassian.jira.gadgets:dashboard-page' does not exist!
      	at com.atlassian.web.servlet.plugin.DynamicAuthorizationServletForwarder.forward(DynamicAuthorizationServletForwarder.java:55) [?:?]
      	at com.atlassian.web.servlet.plugin.DynamicAuthorizationServletForwarder.forwardSafely(DynamicAuthorizationServletForwarder.java:83) [?:?]
      	at com.atlassian.web.servlet.plugin.SanitizingServletForwarder.forwardSafely(SanitizingServletForwarder.java:48) [?:?]
      	at com.atlassian.web.servlet.plugin.RememberingServletForwarder.forwardSafely(RememberingServletForwarder.java:75) [?:?]
      	at com.atlassian.web.servlet.plugin.ResolvingServletForwarder.forwardSafely(ResolvingServletForwarder.java:52) [?:?]
      	at com.atlassian.web.servlet.plugin.request.RedirectInterceptingResponse.lambda$null$0(RedirectInterceptingResponse.java:43) [?:?]
      	at java.util.Optional.map(Optional.java:215) [?:1.8.0_77]
      	at com.atlassian.web.servlet.plugin.request.RedirectInterceptingResponse.lambda$sendRedirect$1(RedirectInterceptingResponse.java:43) [?:?]
      	at java.util.Optional.flatMap(Optional.java:241) [?:1.8.0_77]
      	at com.atlassian.web.servlet.plugin.request.RedirectInterceptingResponse.sendRedirect(RedirectInterceptingResponse.java:43) [?:?]
      	at javax.servlet.http.HttpServletResponseWrapper.sendRedirect(HttpServletResponseWrapper.java:138) [servlet-api.jar:?]
      	at com.atlassian.core.filters.HeaderSanitisingResponseWrapper.sendRedirect(HeaderSanitisingResponseWrapper.java:85) [atlassian-core-5.0.6.jar:?]
      (...)
      

      Notes

      • It doesn't look like anything breaks permanently. JIRA works fine after a restart.
      • Uninstalling JSD 3.0.10 on JIRA 7.2.0 before installing JSD 3.2.0 does not make a difference.

      I have included the full catalina.out from the moment JSD begun its update and the full stack trace above in the following attachments:

      Workarounds

      • Restart JIRA. No errors occur after that.
      • When upgrading JIRA to 7.2.0, use a clean jira-home folder, without any add-ons.

          Form Name

            [JSDSERVER-4220] JIRA becomes inacessible after upgrading JIRA Service Desk to 3.2.0.

            Thanks Tim, that's great! I felt like I was really brute-forcing it but that approach seems really clean.

            Steven F Behnke added a comment - Thanks Tim, that's great! I felt like I was really brute-forcing it but that approach seems really clean.

            Tim Eddelbüttel added a comment - - edited

            When i upgrade our JIRA (with Agile and Service Desk installed) from 6.4.x to 7.0.x, it gives me a lot of headaches.
            I've done many test upgrades, and see the upgrade log which was for me not a clean update. As sfbehnke already said, the main problem was add-ons incl. JIRA Service Desk itself.
            Removing them before an upgrade will work, but for me it's not a clean update when the log file told me that e.g. ScriptRunner Listener, CustomField XYZ isn't found.

            The solution for me was the following:

            1. Shutdown your server and prepare your update (in my case JIRA Software which bundles the new Software "application" and remove the old Agile add-ons on startup)
            2. Then i create bash script (reproducible on test and live) that removes the old plugin version from the installed-plugins directory and downloads the compatible version that i want, extracts them (.obr) and copy the .jar. (Agile and Service Desk will only removed in this step.
              Few examples
              # JIRA Agile
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/plugin.*.jira-greenhopper-plugin-*.jar
              
              # JIRA Service Desk
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/plugin_*_jira-servicedesk-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/servicedesk-automation-modules-plugin-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/servicedesk-automation-plugin-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/atlassian-chaperone-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/atlassian-client-resource-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/atlassian-pocketknife-api-commons-plugin-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/pocketknife-features-plugin-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/atlassian-timed-promise-plugin-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/jira-email-processor-plugin-*.jar
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/jira-workinghours-plugin-*.jar
              
              # Adaptavist Sriptrunner for JIRA Standard Edition
              sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/plugin.*.scriptrunner-jira-*.jar
              sudo wget https://marketplace-cdn.atlassian.com/files/artifact/1da8c9d3-4a6e-438f-b9c2-d19d6bf025e0/scriptrunner-jira-4.1.4.jar -P /tmp/jira7/
              sudo cp /tmp/jira7/scriptrunner-jira-4.1.4.jar /opt/atlassian/jira-data/plugins/installed-plugins/
              
              # JIRA Automation Plugin
              sudo rm -rf /opt/Atlassian/jira-data/plugins/installed-plugins/automation-module-*.jar
              sudo rm -rf /opt/Atlassian/jira-data/plugins/installed-plugins/jira-automation-plugin-*.jar
              sudo rm -rf /opt/Atlassian/jira-data/plugins/installed-plugins/jira-automation-spi-*.jar
              sudo wget https://marketplace-cdn.atlassian.com/files/artifact/f890f2a0-0753-42b8-a79b-e6b66cb27e5c/jira-automation-plugin-2.0.0.obr -P /tmp/jira7
              sudo unzip /tmp/jira7/jira-automation-plugin-2.0.0.obr dependencies/automation-module-2.0.0.jar -d /tmp/jira7/
              sudo unzip /tmp/jira7/jira-automation-plugin-2.0.0.obr jira-automation-plugin-2.0.0.jar -d /tmp/jira7/
              sudo unzip /tmp/jira7/jira-automation-plugin-2.0.0.obr dependencies/jira-automation-spi-2.0.0.jar -d /tmp/jira7/
              sudo cp /tmp/jira7/dependencies/automation-module-2.0.0.jar /opt/Atlassian/jira-data/plugins/installed-plugins/
              sudo cp /tmp/jira7/jira-automation-plugin-2.0.0.jar /opt/Atlassian/jira-data/plugins/installed-plugins/
              sudo cp /tmp/jira7/dependencies/jira-automation-spi-2.0.0.jar /opt/Atlassian/jira-data/plugins/installed-plugins/
              
            3. Get JIRA Service Desk Application
              wget https://www.atlassian.com/software/jira/downloads/binary/atlassian-servicedesk-3.0.11.tar.gz
              
              tar xvzf atlassian-servicedesk-3.0.11.tar.gz
              
              sudo cp -r ~/atlassian-jira-servicedesk-3.0.11-standalone/atlassian-jira/WEB-INF/application-installation/* /opt/atlassian/jira/atlassian-jira-software-7.0.11-standalone/atlassian-jira/WEB-INF/application-installation/
              
            4. Cleanup your plugin cache folder
            5. Start your  server

            When JIRA starts, it picks booth applications (Software + Service Desk) from the application-installation and starts the update process without interaction. Because all plugins are also compatible, there will be no problems within the startup due to incompatibility.

            I hope that Atlassian will bring up a download package what contains Software AND Service Desk and not only Software OR Service Desk. This will make update easier.

            This are a few manual steps, but i do this with JIRA 7.0, 7.1 and 7.2 and have no problems.

            Regards,
            Tim

            Tim Eddelbüttel added a comment - - edited When i upgrade our JIRA (with Agile and Service Desk installed) from 6.4.x to 7.0.x, it gives me a lot of headaches. I've done many test upgrades, and see the upgrade log which was for me not a clean update. As sfbehnke already said, the main problem was add-ons incl. JIRA Service Desk itself. Removing them before an upgrade will work, but for me it's not a clean update when the log file told me that e.g. ScriptRunner Listener, CustomField XYZ isn't found. The solution for me was the following: Shutdown your server and prepare your update (in my case JIRA Software which bundles the new Software "application" and remove the old Agile add-ons on startup) Then i create bash script (reproducible on test and live) that removes the old plugin version from the installed-plugins directory and downloads the compatible version that i want, extracts them (.obr) and copy the .jar. (Agile and Service Desk will only removed in this step. Few examples # JIRA Agile sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/plugin.*.jira-greenhopper-plugin-*.jar # JIRA Service Desk sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/plugin_*_jira-servicedesk-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/servicedesk-automation-modules-plugin-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/servicedesk-automation-plugin-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/atlassian-chaperone-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/atlassian-client-resource-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/atlassian-pocketknife-api-commons-plugin-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/pocketknife-features-plugin-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/atlassian-timed-promise-plugin-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/jira-email-processor-plugin-*.jar sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/jira-workinghours-plugin-*.jar # Adaptavist Sriptrunner for JIRA Standard Edition sudo rm -rf /opt/atlassian/jira-data/plugins/installed-plugins/plugin.*.scriptrunner-jira-*.jar sudo wget https: //marketplace-cdn.atlassian.com/files/artifact/1da8c9d3-4a6e-438f-b9c2-d19d6bf025e0/scriptrunner-jira-4.1.4.jar -P /tmp/jira7/ sudo cp /tmp/jira7/scriptrunner-jira-4.1.4.jar /opt/atlassian/jira-data/plugins/installed-plugins/ # JIRA Automation Plugin sudo rm -rf /opt/Atlassian/jira-data/plugins/installed-plugins/automation-module-*.jar sudo rm -rf /opt/Atlassian/jira-data/plugins/installed-plugins/jira-automation-plugin-*.jar sudo rm -rf /opt/Atlassian/jira-data/plugins/installed-plugins/jira-automation-spi-*.jar sudo wget https: //marketplace-cdn.atlassian.com/files/artifact/f890f2a0-0753-42b8-a79b-e6b66cb27e5c/jira-automation-plugin-2.0.0.obr -P /tmp/jira7 sudo unzip /tmp/jira7/jira-automation-plugin-2.0.0.obr dependencies/automation-module-2.0.0.jar -d /tmp/jira7/ sudo unzip /tmp/jira7/jira-automation-plugin-2.0.0.obr jira-automation-plugin-2.0.0.jar -d /tmp/jira7/ sudo unzip /tmp/jira7/jira-automation-plugin-2.0.0.obr dependencies/jira-automation-spi-2.0.0.jar -d /tmp/jira7/ sudo cp /tmp/jira7/dependencies/automation-module-2.0.0.jar /opt/Atlassian/jira-data/plugins/installed-plugins/ sudo cp /tmp/jira7/jira-automation-plugin-2.0.0.jar /opt/Atlassian/jira-data/plugins/installed-plugins/ sudo cp /tmp/jira7/dependencies/jira-automation-spi-2.0.0.jar /opt/Atlassian/jira-data/plugins/installed-plugins/ Get JIRA Service Desk Application wget https: //www.atlassian.com/software/jira/downloads/binary/atlassian-servicedesk-3.0.11.tar.gz tar xvzf atlassian-servicedesk-3.0.11.tar.gz sudo cp -r ~/atlassian-jira-servicedesk-3.0.11-standalone/atlassian-jira/WEB-INF/application-installation/* /opt/atlassian/jira/atlassian-jira-software-7.0.11-standalone/atlassian-jira/WEB-INF/application-installation/ Cleanup your plugin cache folder Start your  server When JIRA starts, it picks booth applications (Software + Service Desk) from the application-installation and starts the update process without interaction. Because all plugins are also compatible, there will be no problems within the startup due to incompatibility. I hope that Atlassian will bring up a download package what contains Software AND Service Desk and not only Software OR Service Desk. This will make update easier. This are a few manual steps, but i do this with JIRA 7.0, 7.1 and 7.2 and have no problems. Regards, Tim

            Steven F Behnke added a comment - - edited

            I can confirm my own upgrade path from JIRA 6.4.8. I experienced breakages at each step of the way unless I took an iterative approach.

            1. Upgrade to JIRA 7.0.x
            2. Upgrade Service Desk to 3.0.x
            3. Upgrade Software to 7.0.x
            4. Upgrade to JIRA 7.1.x
            5. Upgrade Service Desk to 3.1.x
            6. Upgrade Software to 7.1.x
            7. Upgrade JIRA to 7.2.x
            8. Upgrade Service Desk to 3.2.x
            9. Upgrade Software to 7.2.x

            I haven't gone to JIRA 7.3.x yet though, so I cannot comment on where to go after 7.2.x/3.2.x. A lot of problems we ran into stemmed from plugins we had installed. Consider the following advice: 

            • Before upgrading from JIRA 6.4.x, upgrade all add-ons as far as they will allow
            • Enable ALL bundled Atlassian plugins and plugin modules, even things like HipChat you may not be using.
            • Remove all third-party add-ons (don't delete their plugin data, just uninstall the plugin)
            • Upgrade to JIRA 7.0.x
            • Install all add-ons, including upgrading JIRA Service Desk (allowing their upgrade tasks to complete)
            • Remove all third-party add-ons again
            • Upgrade to JIRA 7.1.x
            • Install all third-party add-ons again, including upgrading Service Desk
            • Remove all add-ons again
            • Upgrade to JIRA 7.2.x

            Steven F Behnke added a comment - - edited I can confirm my own upgrade path from JIRA 6.4.8. I experienced breakages at each step of the way unless I took an iterative approach. Upgrade to JIRA 7.0.x Upgrade Service Desk to 3.0.x Upgrade Software to 7.0.x Upgrade to JIRA 7.1.x Upgrade Service Desk to 3.1.x Upgrade Software to 7.1.x Upgrade JIRA to 7.2.x Upgrade Service Desk to 3.2.x Upgrade Software to 7.2.x I haven't gone to JIRA 7.3.x yet though, so I cannot comment on where to go after 7.2.x/3.2.x. A lot of problems we ran into stemmed from plugins we had installed. Consider the following advice:  Before upgrading from JIRA 6.4.x, upgrade all add-ons as far as they will allow Enable ALL bundled Atlassian plugins and plugin modules, even things like HipChat you may not be using. Remove all third-party add-ons (don't delete their plugin data, just uninstall the plugin) Upgrade to JIRA 7.0.x Install all add-ons, including upgrading JIRA Service Desk (allowing their upgrade tasks to complete) Remove all third-party add-ons again Upgrade to JIRA 7.1.x Install all third-party add-ons again, including upgrading Service Desk Remove all add-ons again Upgrade to JIRA 7.2.x

            Am I reading this right? The upgrade path from JIRA v6.x if you have JIRA Service Desk is now a three stage upgrade? I went through all the release notes and the closest thing I see to a mention of this is a note in the upgrade instructions for JIRA Service Desk 3.2 saying the opposite, that you can upgrade directly from JSD 3.0 to JSD 3.2:

            • Make sure you have at least JIRA Service Desk 3.0 and JIRA 7.0
            • If you don't have JIRA Service Desk 3.0 or JIRA 7.0, first upgrade to JIRA Service Desk 3.0 and JIRA 7.0. Then, upgrade to JIRA Service Desk 3.2 and JIRA 7.2.

            As far as I can tell, here's the upgrade path. 

            Start with JIRA 6.4.x

            1. Upgrade JIRA to 7.0.0
            2. Upgrade JSD to 3.0.x
            3. Upgrade JIRA to 7.1.1
            4. Upgrade JSD to 3.1.1
            5. Upgrade JIRA to 7.3.6
            6. Upgrade JSD to 3.5.0

            Logan Hawkes added a comment - Am I reading this right? The upgrade path from JIRA v6.x if you have JIRA Service Desk is now a three stage upgrade? I went through all the release notes and the closest thing I see to a mention of this is a note in the upgrade instructions for  JIRA Service Desk 3.2  saying the opposite, that you can upgrade directly from JSD 3.0 to JSD 3.2: Make sure you have at least JIRA Service Desk 3.0 and JIRA 7.0 If you don't have JIRA Service Desk 3.0 or JIRA 7.0, first upgrade to JIRA Service Desk 3.0 and JIRA 7.0. Then, upgrade to JIRA Service Desk 3.2 and JIRA 7.2. As far as I can tell, here's the upgrade path.  Start with JIRA 6.4.x Upgrade JIRA to 7.0.0 Upgrade JSD to 3.0.x Upgrade JIRA to 7.1.1 Upgrade JSD to 3.1.1 Upgrade JIRA to 7.3.6 Upgrade JSD to 3.5.0

            Hi everyone,

            Thanks for your patience.

            We've investigated the issue and found out the root cause. This problem happens only when you upgrade from 3.0.x and 3.1.x to any thing from 3.2.0 and above.

            A possible fix for this is to release a new version of 3.1.x (3.1.11 in particular), and you then can upgrade to 3.1.11 first before upgrading to your desire version (>= 3.2.0). However, this approach sounds more painful than restarting your instance after upgrade from 3.0.x/3.1.x to anything above 3.2.0. So we marked this as won't fix for now.

            We can guarantee that this only happens once, and any upgrades from 3.2.x to the latest version, you would not have to restart JIRA to get it work.

            Sorry for any convenience this might cause.

            Regards,

            JIRA Service Desk Server team.

            Nhi Nguyen (Inactive) added a comment - Hi everyone, Thanks for your patience. We've investigated the issue and found out the root cause. This problem happens only when you upgrade from 3.0.x and 3.1.x to any thing from 3.2.0 and above. A possible fix for this is to release a new version of 3.1.x (3.1.11 in particular), and you then can upgrade to 3.1.11 first before upgrading to your desire version (>= 3.2.0). However, this approach sounds more painful than restarting your instance after upgrade from 3.0.x/3.1.x to anything above 3.2.0. So we marked this as won't fix for now. We can guarantee that this only happens once, and any upgrades from 3.2.x to the latest version, you would not have to restart JIRA to get it work. Sorry for any convenience this might cause. Regards, JIRA Service Desk Server team.

            S Stack added a comment -

            JIRA Data Center 7.2.7

            Seeing this same error in our logs during a UPM plugin update.

             

            S Stack added a comment - JIRA Data Center 7.2.7 Seeing this same error in our logs during a UPM plugin update.  

            Same issue here after upgrading to version 3.3.0:

            java.lang.IllegalArgumentException: Root page 'com.atlassian.jira.gadgets:dashboard-page' does not exist!

            After restart it is working again.

            Deleted Account (Inactive) added a comment - Same issue here after upgrading to version 3.3.0: java.lang.IllegalArgumentException: Root page 'com.atlassian.jira.gadgets:dashboard-page' does not exist! After restart it is working again.

            Hi,

            just ran into the same issue when upgrading to Service Desk 3.3.0

            => Seems to be an ongoing issue, and yes, we thought a lot more would be broken before restarting JIRA did solve the issue for now.

            Please see what you can do aboiut this bug,

            Thanks,

            Andreas

             

            PS: Running JIRA / Service desk as Windows installartions with SQL Server as DB backend.

            Andreas Kordwig added a comment - Hi, just ran into the same issue when upgrading to Service Desk 3.3.0 => Seems to be an ongoing issue, and yes, we thought a lot more would be broken before restarting JIRA did solve the issue for now. Please see what you can do aboiut this bug, Thanks, Andreas   PS: Running JIRA / Service desk as Windows installartions with SQL Server as DB backend.

            IT Pinterest added a comment - - edited

            We ran into this today when upgrading via the UI as well. Restarting JIRA did resolve the problem for us, but I would be lying if I said we didn't start sweating.

            IT Pinterest added a comment - - edited We ran into this today when upgrading via the UI as well. Restarting JIRA did resolve the problem for us, but I would be lying if I said we didn't start sweating.

            Hi!

            Same issue here. Can we have a fix please?

            Regards,
            Nicolas.

            Nicolas Esteves added a comment - Hi! Same issue here. Can we have a fix please? Regards, Nicolas.

              mwinsen Marty (Inactive)
              vfontes Vinicius Fontes
              Affected customers:
              26 This affects my team
              Watchers:
              52 Start watching this issue

                Created:
                Updated:
                Resolved: