Details
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Bug
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Resolution: Unresolved
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Medium
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None
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5.4.15, 5.12.4
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None
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1
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Severity 3 - Minor
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1
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Description
Issue Summary
When creating tickets via JSM customer portal and there are plugins that update the ticket after creation, some webhook (sync or async) payloads for the update present errors related to permission. The message in the payload for some random fields are sent with content as:Â
"customfield_10120":{"errorMessage":"The action performed required a logged in user. Please log in and try again.","i18nErrorMessage":{"i18nKey":"sd.admin.servicedesk.error.authenticated.user.required","parameters"...
This error is easily reproduced using Atlassian Proforma and JSM. With that, this plugin was used to reproduce the error presented in next sections, however the bug may not be limited only to it.
Given that, when using JSM with Proforma forms, and there are "Linked Jira Field" in form questions (when the question maps a value to any Jira field), the plugin updates the issue after creation which triggers a JSM webhook payload for the "jira:issue_updated" event. There we observe fields not being sent correctly.
This is reproducible on Data Center: yes
Steps to Reproduce
- Setup a webhook destination on Jira to send a message when the issue is created/updated.
- Create a form and in a question, map the response to save the data to any field ("LINKED JIRA FIELD")
- Setup the form to be used in a Jira SM project.
- Create an issue in Jira SM using the created form.
Expected Results
All webhook payloads with all fields correctly set.
Actual Results
The issue_created payload is correctly sent (example from lab focusing in some fields):
created: 2024-02-15T14:23:08.805+0000 ... customfield_10120: null customfield_10121: null ... description: Description test ... summary:Summary test
However the issue_updated payload, presented some errors:
customfield_10120 {2} errorMessage: The action performed required a logged in user. Please log in and try again. ... customfield_10121 {2} errorMessage: The action performed required a logged in user. Please log in and try again. ... description: Description test ... summary: Summary test ... updated: 2024-02-15T14:23:09.171+0000 ... issue_event_type_name: issue_updated
We noticed the custom field with errorMessage can vary during this update.
Workaround
Currently, there is no known workaround for this behavior. A workaround will be added here when available.
This behavior is not seen on Jira Software (again using Proforma as basis for the test).
Attachments
Issue Links
- causes
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FORMDC-785 When creating tickets via forms the mapped fields for custom fields are not sending correctly on webhooks
- Long Term Backlog
- is resolved by
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WEBHOOKS-160 Loading...