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  1. Jira Service Management Data Center
  2. JSDSERVER-11086

Insight - Filter Assign Scope (strict)/Filter Issue Scope can be impacted by custom field(s) outside the issue context - Regression of Jira bugs

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    • Icon: Bug Bug
    • Resolution: Won't Fix
    • Icon: High High
    • None
    • 4.20.5
    • None

      Root Cause

      This bug with Insight Custom fields' Assign Scope can be caused by either of the following Jira bugs:

      • JSWSERVER-21241 : Custom field(s)'s value(s) are retained even if the field goes out of scope/context by editing the issue type of an existing issue
      • JRASERVER-71292 : Jira allows illegal edit (issue type) through /rest/api/2/issue/<ISSUE-KEY>

      Problem

      Insight - Filter Assign Scope Strict can be impacted by custom field(s) outside the context of the issue.

      Use Case:

      • Object Type X has a one-to-one relationship with Object Type Y
      • Create two issue type restricted Insight Objects custom fields viz., Parent CF 1 restricted to Issue Type A and Parent CF 2 restricted to Issue Type B both for Object Type X
      • Create another Insight custom field which is not restricted to any issue type viz., Child CF for Object Type Y
      • Have an Filter Assign Scope for Child CF with an IQL which depends on both Parent CF 1, Parent CF 2
      • Mark the Assign Scope Filter strict
      • Create an issue of the Issue Type A with a value in Parent CF 1 which should populate the Child CF due to the Filter Assign Scope (Strict)
      • Move the issue to Issue Type B through
        • By editing the ticket and changing the issue type (if they share the same workflow) exploiting JSWSERVER-21241
        • Or, through REST API exploiting JRASERVER-71292

      Expected Results:

      Insight CF's assign scope does not take Parent CF 1 into consideration as its not in context anymore

      Actual Results:

      • Parent CF 1 is out of scope it won't show up anymore but Child CF will continue to show the old referenced value
      • Select a new value for Parent CF 2 and that would cause the Child CF to now show two Object Type Y values as the assign scope IQL still considers the value in Parent CF 1 even though it's not in context anymore

      Workaround

      • Use the jira UI to move the ticket back to the previous issue type -> Move the issue back to the new issue type (Jira would remove the field value which is about to go out of context)
      • Add the Parent CF 1 in the context of Issue Type B. Edit the issue and remove the value in Parent CF 1 and save. The Assign scope Strict would populate the correct value in Child CF in accordance to Parent CF 2 which is the only parent field in context.

      Note: The same behavior will occur also when Manually editing an Issue / Ticket that has "hidden" CF values: if the Filter Issue scope has Placeholders for out of context placeholders... (and Filter Assign Scope is NOT Strict).
      when Filter Assign is set to Strict - the issue is more noticeable, due to the automatic populating of the Insight CF...

              90b610c8691b Alina Starovoit (Inactive)
              smitra2@atlassian.com Suddha
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                Created:
                Updated:
                Resolved: