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Bug
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Resolution: Timed out
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Medium
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None
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7.6.7, 7.11.2
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7.06
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1
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Severity 2 - Major
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Summary
- When creating an issue the issue will be validated (issueService.validateCreate).
- Part of this validation checks the issue fields, one of those fields being the Security Level (SecurityLevelSystemField.validateParams).
- SecurityLevelSystemField.validateParams only checks that the selected security level exists, not that it is valid for the project the issue is created in.
- SecurityLevelSystemField.validateParams does not return an error when the security level is not valid for the project.
Steps to Reproduce
JIRA API:
- Set up project + one security scheme
- Create an issue, set security to a valid level in the scheme, no problems
- Do this using the JIRA API
- Change to a different scheme with different levels
- Create issue using same level as before
- issue is created and is not accessible to any user (because of invalid security level)
JSD Steps:
- Set up security on the project
- Change request type to have security level field, hidden, default value is a valid level
- Create issue, works fine, security level is correct
- Change to a different security scheme with different levels
- Create issue using JSD portal - issue is created but cannot be viewed by anyone because of invalid security level
- Note that if you go back to the request type and configure the default value for hidden field - You will be presented with the correct options to choose from. No warning or error. (should show "The security level is invalid.")
- If the security level did not exist then there would be an error in the portal and when viewing the default value
Expected Results
Jira will validate Security Level and will return an error (SecurityLevelSystemField.validateParams returns an error when the security level is not valid for the project).
Actual Results
- An issues being created with an invalid security level.
- These issues are not accessible by any user through the JIRA UI. Database modification is required to fix these issues.
Workaround
- None.
- Database modification is required to fix these issues.
- causes
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JSDSERVER-16169 Migrating issue security schemes corrupts new customer requests if the Issue Security field is preset in JSM Data Center
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- Closed
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- relates to
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JSDSERVER-5981 Alert admin when request type is configured with invalid default value
- Closed