Uploaded image for project: 'Jira Data Center'
  1. Jira Data Center
  2. JRASERVER-40477

Allow forwarded email attachments to be detected by JIRA mail handler and renamed to .eml or .msg

XMLWordPrintable

    • 1
    • 28
    • We collect Jira feedback from various sources, and we evaluate what we've collected when planning our product roadmap. To understand how this piece of feedback will be reviewed, see our Implementation of New Features Policy.

      NOTE: This suggestion is for JIRA Server. Using JIRA Cloud? See the corresponding suggestion.

      Problem Definition

      Currently if you forward a mail as an attachment, for example using the desktop version of Microsoft Outlook or Thunderbird, it shows up in a JIRA issue as a file with no extension containing a MIME formatted file containing xhtml with MS Office's extensions. Because there is no extension, clicking on the file does not open it in the appropriate way.

      Note 1: The same issue appears to occur when we attach the msg file without using the forwarding functionality in Outlook. In this case as well, Outlook does not include the file extension in the attachment.

      Note 2: If the same mail attachment was sent to Jira via the mail web browser, the file extension exists in the original email and the .msg file can be viewed correctly.

      Suggested Solution

      Adding a check to rename such a file to be called .eml or .msg would give the necessary hint required for a mail program to successfully open such an attachment.

      Cause

      Attaching an email in a client such as Gmail will provide a filename for the attachment, for example:

      Content-Type: message/rfc822; name="test.eml"
      Content-Disposition: attachment; filename="test.eml"
      Content-Transfer-Encoding: base64
      ...
      

      Attaching an email in Outlook provides no name or filename for the attachment:

      Content-type: message/rfc822
      Content-disposition: attachment
      

      As a result JIRA doesn't know what to name this file.

      Workaround

      • use the web version of Outlook or use another email client (Gmail, etc)

              Unassigned Unassigned
              dmason David Mason (Inactive)
              Votes:
              26 Vote for this issue
              Watchers:
              19 Start watching this issue

                Created:
                Updated: