Summary
If you disable options in the select list and checkbox custom fields the value cannot be selected from the issue but the option is still present in the field in the Plan view if you add the custom field as a column in your plan.
Disabled options should not be able to be selected, but do remain on existing issues, and can still be searched and will show up in reports.
Environment
- Tested on Advanced Roadmaps 3.29.2
Steps to Reproduce
- Go to admin > Issues > custom fields
- find or create a select list custom field
- Under configuration select "Edit Options" to get to the list of options.
- Note Next to each option, you have actions - delete, rename, and disable.
- Disable one of the options
- Add the Custom Field to your plan
- select the drop-down to choose an option from the plan view
Expected Results
The Disabled option is not present, therefore it cannot be selected as a valid option
Actual Results
The Disabled option is present and can be selected and added to new issues
Workaround
No Workaround at this time
- causes
-
JSWSERVER-25434 Adding a multiple-choice custom field to a Program, will make it inaccessible
-
- Closed
-
- relates to
-
JPO-15571 Failed to load
This is a very confusing bug; our organisations were not impacted until recently (with our last round of release management being in Oct 2021) we have been on Jira cloud for some time.
Yet this bug was created in 2020?
It is a very big deal for all disabled options to display in bug / testing / change tickets. The potential of filters to miss brand new or 'required' tickets is high.