Atlassian Status as of 23rd July 2014

      Dear Customers,

      This bug was fixed in JIRA Agile 6.4.3, which will help prevent future rank data corruption from occurring.

      The new release does not attempt to automatically correct any existing rank data corruption that may be present as a result of installing JIRA Agile 6.4.x. The reason behind this is because we feel that the best way to deal with existing cases is with the help of our Support Team.

      If you are upgrading an instance which previously had a 6.4.x version installed, and you find that your problems persist, please contact our Support Team so that they can investigate the state of your ranking data and provide a faster resolution.

      We thank you for your continued patience and hope that you appreciate our open communication style.

      Regards,

      JIRA Agile Team

      Symptoms

      • You're using an Oracle database
      • You're running JAG 6.4.x
      • Creating a new issue is slow and the jira logs have the following warning message
        2014-07-02 09:11:26,257 http-bio-8080-exec-97 WARN xxxxxx 551x7454x6 1hz4f54 xxx.xxx.10.xxx,192.xxx.1.12 /secure/QuickCreateIssue.jspa [greenhopper.customfield.lexorank.LexoRankIndexer] Could not retrieve LexoRank value for issue[id=123317]. Indexing max LexoRank value 

      Some Oracle configurations don't surface the problem however. To confirm your system is affected run these two queries:

       
      SELECT * FROM "AO_60DB71_LEXORANK" WHERE "FIELD_ID" = *insert rank field id here* AND ROWNUM <=2 ORDER BY "RANK" DESC; 
      
       
      SELECT "RANK" FROM (SELECT * FROM "AO_60DB71_LEXORANK" WHERE "FIELD_ID" = *insert rank field id here* ORDER BY "RANK" DESC) WHERE ROWNUM <=2 ; 
      

      If both return the same 2 rows, then it is good. If they differ the ranking in JAG will not work properly.

      To find the Rank field ID, follow the steps below:

      1. Go to Administration > Issues > Custom Fields.
      2. Find the Rank custom field.
      3. Click on the Cog Icon > View.
      4. The URL will change similarly to the example below:
         
        http://yourjira/secure/admin/ConfigureCustomField!default.jspa?customFieldId=10005 
        

        In this example the Rank Field ID is 10005.

      Root cause

      LexoRank code uses a custom SQL select statement to get rank rows and limits the results using a db specific clause. In Oracle's case this is the pseudocolumn ROWNUM.

      We use this column to limit the results, but in a wrong way. We want a query to be sorted by the order by clause before limiting the results. The way we use it will mean we get the first n rows and then sort those rows based on the order by clause.

      http://docs.oracle.com/cd/B28359_01/server.111/b28286/pseudocolumns009.htm#SQLRF00255

      Workaround

      Rollback the JIRA Agile add-on to 6.3.13.1 as per the below steps.

      The only version that can be rolled back to is 6.3.13.1. Any other version will cause significant problems.

      1. Unlock the rank fields as per How to unlock a Locked field.
      2. From JIRA Administration > Issues > Custom Fields (left side menu), rename the rank fields to something else, for example Rank (LexoRank).
      3. Rename the old (Obsolete) fields to their original name 'Rank'.
      4. From JIRA Administration > Manage Add-ons, uninstall JIRA Agile.
      5. Stop JIRA.
      6. Roll-back the JIRA Agile version in the database with the following SQL:
         
        UPDATE propertynumber SET propertyvalue = 42 WHERE id = (SELECT id FROM propertyentry WHERE property_key = 'GreenHopper.Upgrade.Latest.Upgraded.Version'); 
        UPDATE propertystring SET propertyvalue = '42' WHERE id = (SELECT id FROM propertyentry WHERE property_key = 'com.pyxis.greenhopper.jira:build'); 
        
      7. Start JIRA.
      8. Install the previous version of JIRA Agile 6.3.13.1. From JIRA Administration > Add-ons > Manage Add-ons (left side menu), choose 'Upload Add-on' and provide the URL or upload from your computer.
      9. Reindex JIRA.

            [JSWSERVER-10910] Use of ROWNUM in Oracle select statement incorrect

            Hi Michael, thanks for your reply! I already have an open case with support team for this. I commented on this because I just wanted to help my fellow JIRA administrators who face this issue and land on this page know that this issue although marked fixed is really not fixed even on JIRA agile 6.6.

            Narendran Bhojan added a comment - Hi Michael, thanks for your reply! I already have an open case with support team for this. I commented on this because I just wanted to help my fellow JIRA administrators who face this issue and land on this page know that this issue although marked fixed is really not fixed even on JIRA agile 6.6.

            narendran_bhojan please immediately contact our Support team as they are best placed to troubleshoot your particular problem.
            Thanks,
            JIRA Agile Team

            Michael Tokar added a comment - narendran_bhojan please immediately contact our Support team as they are best placed to troubleshoot your particular problem. Thanks, JIRA Agile Team

            We tried JIRA agile 6.6 and still see this issue. This issue needs to be reopened as I do not see an open issue to track this.

            Narendran Bhojan added a comment - We tried JIRA agile 6.6 and still see this issue. This issue needs to be reopened as I do not see an open issue to track this.

            we are on JIRA Agile 6.4.3 with JIRA 6.3.1 and this problem is happening in our production instance

            Ankur Dhawan added a comment - we are on JIRA Agile 6.4.3 with JIRA 6.3.1 and this problem is happening in our production instance

            6.4.3 version fixed the bug for me too. Thank you.

            Rytis Budreika added a comment - 6.4.3 version fixed the bug for me too. Thank you.

            Aitor Morant Inchausti added a comment - - edited

            Thanks to the Atlassian support, our problem was fixed, even the rank problem in boards.
            If you still have this issue with JAG 6.4.3 installed, try to change your NLS_SORT parameter to binary in your database, for example, with this thigger in your JIRA DB scheme

            create or replace
            trigger after_logon
               after logon on schema
                begin
                        execute immediate 'alter session set nls_sort = BINARY';
                end;
            

            Aitor Morant Inchausti added a comment - - edited Thanks to the Atlassian support, our problem was fixed, even the rank problem in boards. If you still have this issue with JAG 6.4.3 installed, try to change your NLS_SORT parameter to binary in your database, for example, with this thigger in your JIRA DB scheme create or replace trigger after_logon after logon on schema begin execute immediate ' alter session set nls_sort = BINARY ' ; end ;

            Aitor Morant Inchausti added a comment - - edited

            We had no luck.. Like @Le Wang, we still have the same slowniness and the problem with the ranking in Agile Board after upgrading and reindexed. We opened again a support ticket with our information.

            Aitor Morant Inchausti added a comment - - edited We had no luck.. Like @Le Wang, we still have the same slowniness and the problem with the ranking in Agile Board after upgrading and reindexed. We opened again a support ticket with our information.

            TechS added a comment -

            On our case, after upgrade JIRA Agile from version 6.4.2 to 6.4.3, errors disappeared from log file and the JIRA performance has returned to normal, slowness disappearing.

            Regards,
            Daniel

            TechS added a comment - On our case, after upgrade JIRA Agile from version 6.4.2 to 6.4.3, errors disappeared from log file and the JIRA performance has returned to normal, slowness disappearing. Regards, Daniel

            This fix (installation of 6.4.3) worked for me. No more errors in the log. One user just called me and asked what has happened, because issue creation works instantly (no more delays).
            So I can only say, thank you

            Regards,

            Siniša

            Siniša Ivanek added a comment - This fix (installation of 6.4.3) worked for me. No more errors in the log. One user just called me and asked what has happened, because issue creation works instantly (no more delays). So I can only say, thank you Regards, Siniša

            ankur.dhawan,

            Performance degradation in JIRA Agile 6.4.x releases has primarily been a result of the bugs in our new ranking algorithm, which are covered in GHS-10872 and this issue. These bugs were causing rank value generation to be slow, which would impact on re-indexing duration if many issues were without a rank value (for example, when a new rank field is created, or issues are created in bulk).

            It is our belief that with these two issues resolved, performance of a running JIRA instance in a good state should be as per normal. "In a good state" means:

            • JIRA Agile's issue ranking table is complete (covers all/most issues) and is not corrupt;
            • JIRA's issue index is complete (covers all/most issues) and is not corrupt.

            Regards,
            JIRA Agile Team

            Michael Tokar added a comment - ankur.dhawan , Performance degradation in JIRA Agile 6.4.x releases has primarily been a result of the bugs in our new ranking algorithm, which are covered in GHS-10872 and this issue. These bugs were causing rank value generation to be slow, which would impact on re-indexing duration if many issues were without a rank value (for example, when a new rank field is created, or issues are created in bulk). It is our belief that with these two issues resolved, performance of a running JIRA instance in a good state should be as per normal. "In a good state" means: JIRA Agile's issue ranking table is complete (covers all/most issues) and is not corrupt; JIRA's issue index is complete (covers all/most issues) and is not corrupt. Regards, JIRA Agile Team

              Unassigned Unassigned
              melias MichaelA (Inactive)
              Affected customers:
              16 This affects my team
              Watchers:
              45 Start watching this issue

                Created:
                Updated:
                Resolved: