Uploaded image for project: 'FishEye'
  1. FishEye
  2. FE-5540

SQL Server 2014 support

    XMLWordPrintable

Details

    • Suggestion
    • Status: Closed (View Workflow)
    • Resolution: Fixed
    • 4.1.0
    • None
    • None
    • Our product teams collect and evaluate feedback from a number of different sources. To learn more about how we use customer feedback in the planning process, check out our new feature policy.

    Description

      Suggestion to support SQL Server 2014.
      Also, after introducing 2014 we could consider reducing options in DB selection dropdown if there are several versions that can be handled in the same way (e.g. "2005", "2008 and newer").

      Notes

      When using MS SQL Server 2014, the following options are expected in the config.xml file for the database tag:

      <database type="sqlserver2012"> 
        <connection dialect="com.cenqua.crucible.hibernate.dialects.SQLServer2008UnicodeDialect"
      

      These settings are automatically applied when performing a migration to a SQLServer database through the user interface. It is required to manually set them when upgrading the SQLServer version from a version prior to 2012.

      Attachments

        Issue Links

          Activity

            People

              pswiecicki Piotr Swiecicki
              grefosco Gustavo Refosco (Inactive)
              Votes:
              10 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: