Uploaded image for project: 'Confluence Data Center'
  1. Confluence Data Center
  2. CONFSERVER-56444

Edit in App does not work when Confluence is integrated with Crowd SSO

XMLWordPrintable

      Summary

      When clicking on the Edit with <App> in the attachment preview page, the registered application (such as Word) will throw an error that downloaded file is corrupt.

      Steps to reproduce

      1. Install Confluence 6.11.0 + Companion App
      2. Attach a word document to a Confluence page
      3. Click on the word document to show in Preview
      4. Click on the Edit with Word
        • Word opens the document fine
      5. Now, integrate Confluence with Crowd SSO
        • Repeat the above test by clicking on the Edit with Word
        • An error will be thrown back saying 'downloaded file is corrupt'

      Expected Result

      Clicking the Edit with <App> should work with Confluence regardless whether Confluence is integrated with Crowd SSO.

      Cause

      When Confluence is integrated with Crowd SSO, the Companion App is unable to download the attachment for editing from Confluence. This results in a login HTML downloaded as the contents of the attachment download.

      Validation

      Open up the Companion App Temp folder and open up the download file.

      • Windows: C:\Users\username\.atlassian-companion\<hash>\file (Note: The user may need to "Show hidden files and folders" to view this folder)
      • Mac: ~/.atlassian-companion/<hash>/file

      The downloaded file contain HTML contents instead of the actual attachment contents. Renaming this file to .html and opening in a Browser will show that the downloaded contents is a Confluence login page.

              dluong Duy Truong Luong
              hlam@atlassian.com Eric Lam
              Votes:
              41 Vote for this issue
              Watchers:
              48 Start watching this issue

                Created:
                Updated:
                Resolved: