Details
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Bug
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Resolution: Fixed
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High
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6.11.0, 6.12.0
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15
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Severity 3 - Minor
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75
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Description
Summary
When clicking on the Edit with <App> in the attachment preview page, the registered application (such as Word) will throw an error that downloaded file is corrupt.
Steps to reproduce
- Install Confluence 6.11.0 + Companion App
- Attach a word document to a Confluence page
- Click on the word document to show in Preview
- Click on the Edit with Word
- Word opens the document fine
- Now, integrate Confluence with Crowd SSO
- Repeat the above test by clicking on the Edit with Word
- An error will be thrown back saying 'downloaded file is corrupt'
Expected Result
Clicking the Edit with <App> should work with Confluence regardless whether Confluence is integrated with Crowd SSO.
Cause
When Confluence is integrated with Crowd SSO, the Companion App is unable to download the attachment for editing from Confluence. This results in a login HTML downloaded as the contents of the attachment download.
Validation
Open up the Companion App Temp folder and open up the download file.
- Windows: C:\Users\username\.atlassian-companion\<hash>\file (Note: The user may need to "Show hidden files and folders" to view this folder)
- Mac: ~/.atlassian-companion/<hash>/file
The downloaded file contain HTML contents instead of the actual attachment contents. Renaming this file to .html and opening in a Browser will show that the downloaded contents is a Confluence login page.
Attachments
Issue Links
- relates to
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CONFSERVER-57486 Edit in App does not work when Confluence is integrated with Custom SSO
- Closed
- mentioned in
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