Details
-
Bug
-
Resolution: Unresolved
-
Medium
-
None
-
5.2.4, 6.0.6
-
20
-
Severity 2 - Major
-
7
-
Description
Symptoms
When visiting the License Details screen in Confluence Admin, you may notice that the expiry date of the license is sooner or later than your invoice suggests - or the details in My Atlassian. The discrepancy may be a day or more. Actually the license expires the earlier or later than the expiry date shown in My Atlassian.
For example : you own the license expiring at Aug 28th 2019 in My Atlassian, the license expiry date shown License Details screen is Aug 27th 2019 in Japan Standard Time. This license expires at Aug 27th 2019 23:00:00 in the local time.
Cause
There is a discrepancy in the timezone when the products and Atlassian license system handle a license expiry date.
The License contains license a expiry date in string format like 'YYYY-MM-DD' at US Central Standard Time (UTC-6). In Confluence, this license expiry date is converted to UTC timestamp by complementing time with '00:00:00' as Australian Eastern Standard Time (UTC+10) and is displayed at using your local time zone.
In this case, the license expiry date is converted to Aug 28th 2019 00:00 in Australian Eastern Standard Time (UTC+10). That is, the license expires at Aug 27th 2019 23:00 in Japan Standard time. License Details shows Aug 27th 2019 s the license expiry in the local timezone.
Attachments
Issue Links
- is related to
-
BSERV-11038 Bitbucket DC license expired before the last day on my.atlassian.com
- Gathering Impact
-
JRASERVER-38375 Support expires one day earlier in product
- Gathering Impact