Uploaded image for project: 'Confluence Server and Data Center'
  1. Confluence Server and Data Center
  2. CONFSERVER-21002

Prevent running with known-broken JDKs (e.g. 1.6.0_18)

    XMLWordPrintable

Details

    • Suggestion
    • Status: Closed (View Workflow)
    • Resolution: Answered
    • None
    • None
    • We collect Confluence feedback from various sources, and we evaluate what we've collected when planning our product roadmap. To understand how this piece of feedback will be reviewed, see our Implementation of New Features Policy.

    Description

      NOTE: This suggestion is for Confluence Server. Using Confluence Cloud? See the corresponding suggestion.

      It would be good to check at start-up whether we're running with a JDK which is known to have crashing bugs with Confluence. If detected, we could prevent the application starting up and show a meaningful error message.

      This is closely related to CONF-19049, where recent patch versions of Java 1.6 have moderately frequent crashing bugs with Confluence/Velocity for some customers.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              matt@atlassian.com Matt Ryall
              Votes:
              5 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: