Details
-
Bug
-
Resolution: Unresolved
-
Low
-
2
-
Minor
-
Description
// code placeholder
Issue Summary
Specific fields in Jira ITSM projects are not displayed inside Jira macro.
Steps to Reproduce
- Create a Jira ITSM project and a Jira issue inside it.
- Use the 'Services' menu and create a Service. This will populate the 'Affected Services' field( Screenshot 1).
- Invoke this field from a Jira macro. This field data is not displayed in the macro. (Screenshot 2).
Expected Results
The affected Services field should be displayed inside the Jira macro
Actual Results
The affected Services field is not displayed in the Jira macro.
Workaround
Currently, there is no known workaround for this behavior. A workaround will be added here when available
Root Cause
Confluence Cloud's Jira-Macro didn't accept this service field yet.
Field schema:
{ "id": "customfield_10243", "key": "customfield_10243", "name": "Affected services", "untranslatedName": "Affected services", "custom": true, "orderable": true, "navigable": true, "searchable": true, "clauseNames": [ "Affected services", "cf[10243]" ], "schema": { "type": "array", "items": "service-entity-field", "custom": "com.atlassian.jira.plugins.service-entity:service-entity-field-cftype", "customId": 10243 } },
"customfield_10243": [ { "id": "ari:cloud:graph::service/ab1ceb84-2e4d-11eb-a366-128b42819424/5f35b962-51ea-11ee-af8c-128b42819424" } ],