Uploaded image for project: 'Sourcetree for Windows'
  1. Sourcetree for Windows
  2. SRCTREEWIN-9838

Source Tree Always Asks for BitBucket Password

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: High
    • Resolution: Duplicate
    • Affects Version/s: 3.0.5
    • Fix Version/s: None
    • Component/s: Bitbucket, UX
    • Environment:

      Latest Windows 10

      Microsoft Surface Book

      SourceTree Desktop Application & BitBucket

    • Symptom Severity:
      Severity 2 - Major

      Description

      SourceTree will NOT stop asking for my password.

      I may be confusing some details, but I believe I had a generic BitBucket account under the username dcholth.  At some point BitBucket gave me the option to convert or use this as a Google authenticated account.  I chose this option.

      Since then, SourceTree will not properly save my authentication and continues to ask me for my password.

      I've seen community responses to this, and none of the suggestions have helped.  Steps I've taken to try to correct the issue:

      Access Management:

      Old Bitbucket account password:  When it asks for a password, I can use my OLD (pre-google login) password for it to work.

      OAuth: It shows that Source Tree for windows is authorized.  I've tried Revoking and re-adding to no effect.

      App passwords:  I've created an app password for SourceTree.  I've revoked and re-addeded to no effect.

      I've tried both of these in combinations.

       

      They both work at the start but then after a period of time, or I close source tree, it AGAIN asks me for a password.

      Also note, and I feel like this shouldn't be the case, I can login to my account via my old Bitbucket authentication AND google. 

       

      Version:  3.0.6 (Not yet an option in your Jira tickets)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              dan478431166 Dan Holth
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: