Uploaded image for project: 'Sourcetree for Windows'
  1. Sourcetree for Windows
  2. SRCTREEWIN-8778

Sourcetree flags Git-LFS as outdated, even though current version installed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Needs Triage (View Workflow)
    • Priority: High
    • Resolution: Unresolved
    • Affects Version/s: 2.6.6
    • Fix Version/s: None
    • Component/s: Git
    • Environment:

      Windows 7 x64 with all current updates installed.

       

    • Symptom Severity:
      Severity 3 - Minor

      Description

      Just updated from SourceTree 2.5.5 to SourceTree 2.6.6.  After startup, SourceTree shows yellow flag that says "A newer version of Git-LFS is available"

      I check in my SourceTree installation folder, and see two different git-lfs.exe exists.

      One is v2.0.2, which is the one SourceTree is detecting.  The other is v2.4.2, which is not being detected.

      For some reason, the update to SourceTree v2.6.6 didn't properly cleanup the older git-lfs.exe

      New version was in C:\Users\<my user name>\AppData\Local\Atlassian\SourceTree\git_local\mingw32\bin\

      Old version was in C:\Users\<my user name>\AppData\Local\Atlassian\SourceTree\git_local\mingw32\libexec\git-core\

      All the other files in the same directory as the old version all seemd to be current, e.g. git-*.exe files from embedded Git were all for version v2.7.1.2 (the current version)

      To me it seems like something has changed with the placement of git-lfs.exe, and the updater is not cleaning out the old git-lfs.exe when it runs.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            jason.armistead Jason Armistead
            Votes:
            6 Vote for this issue
            Watchers:
            12 Start watching this issue

              Dates

              Created:
              Updated: