Uploaded image for project: 'Sourcetree for Windows'
  1. Sourcetree for Windows
  2. SRCTREEWIN-13736

Cannot Remove Keys from SSH Agent

    XMLWordPrintable

Details

    • Bug
    • Status: Needs Triage (View Workflow)
    • Low
    • Resolution: Unresolved
    • 3.4.7
    • None
    • General
    • None
    • Minor

    Description

      I am using SourceTree on Windows.  I have SSH keys to validate the server connection.  So, when I start Sourcetree it launches the SSH Agent which then asks me for the passwords for each key. That is fine.

      However, while I can see an option in SourceTree to "Add SSH Key" I cannot see how to remove one.  My actual problem is that, due to a misleading error message, I re-added the key and it now has the same key multiple times and asks for too many passwords at start-up!  But, more generally, I would like to be able to list and remove keys from the SSH agent.

      I have tried using command line ssh-add but it says

      Error connecting to agent: No such file or directory

      (Tried this both with windows CMD shell and in the Git bash terminal that SourceTree launches)

      I see a running ssh-agent.exe process in Task Manager when SourceTree is running - in the Details tab. But in the Services tab it says the service is stopped. So, I guess SourceTree has started it but how do I connect to it? Alternatively, how to tell SourceTree not to start it's own but use the Windows Service?

      I am using the OpenSSH SSH client (in SourceTree options).

      If SourceTree is managing the SSH Agent (as it seems to be) and given it gives me the option to add a key, it should either include options to remove one or to launch some other UI (or even CLI) that can do so.

      Attachments

        Activity

          People

            Unassigned Unassigned
            8c980c9624f4 Adam Conway
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: