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  1. Jira Service Management Data Center
  2. JSDSERVER-12625

Updating a customfield using Automation for Jira does not always initiate proper reindexing which affects the queue and issue filters

    • Icon: Bug Bug
    • Resolution: Tracked Elsewhere
    • Icon: High High
    • None
    • 5.3.3, 5.4.6
    • Queues

      Issue Summary

      When an Automation rule (from Automation For Jira) is used to update a custom field in a ticket from a JSM project, the custom field value is not always indexed, as a result any feature relying on issue search does not show up to date information such as:

      • Issue Filters
      • JSM queues

      Root Cause

      When a field is updated by an Automation rule, the data in the database is correctly updated but intermittently the reindexing does not occur and due to that the JSM queue breaks and gives incorrect results. A custom field is updated correctly in the Database

      This is not seen when the field is manually updated but only occurs when using the Automation rule to update the field.

      SdSerialisedOffThreadProcessor:thread-4 runs AsyncMessageProcessorImpl#masterQueueSpinConsumer, processing events that are added after it has started. The loop runs without refreshing its thread local caches when necessary and due to that the indexes are not properly updated which causes the issue.

      This is reproducible on Data Center: yes

      Steps to Reproduce

      1. Customer uses A4J to update the Select List (single choice) customfield to
        • “Customer” after a JSM customer adds a comment
        • “Agent ” after a JSM agent adds a comment
      2. Customer has a JSM queue that uses this customfield value in the queue JQL query to track tickets waiting on support.
      3. Once the tickets come into this queue then agents respond to the customer

      Expected Results

      Everything works as expected and whenever the custom field is updated then the tickets are correctly seen in the queue and helps the agents to work on it.

      Actual Results

      This issue occurs intermittently sometimes even after the custom field data is properly updated still the JQL query results are incorrect and due to that the JSM queue does not have the correct tickets which causes a lot of problems for the users to track the tickets.

       

      Workaround

      To be added later

        1. image-2023-08-22-09-04-58-046.png
          54 kB
          Benjamin Suess
        2. a829112a-7bac-49dd-9805-783ef9a39e74.png
          264 kB
          AviGhosh

          Form Name

            [JSDSERVER-12625] Updating a customfield using Automation for Jira does not always initiate proper reindexing which affects the queue and issue filters

            Binoy Nicholas made changes -
            Remote Link Original: This issue links to "Page (Confluence)" [ 912112 ]
            Binoy Nicholas made changes -
            Remote Link New: This issue links to "Page (Confluence)" [ 912112 ]
            Deepak Sidhpura made changes -
            Remote Link New: This issue links to "Page (Confluence)" [ 857512 ]
            Michał Błajet made changes -
            Remote Link New: This issue links to "Page (Confluence)" [ 840668 ]
            SET Analytics Bot made changes -
            UIS Original: 60 New: 56
            Alex Cooksey made changes -
            Resolution New: Tracked Elsewhere [ 15 ]
            Status Original: Short Term Backlog [ 12074 ] New: Closed [ 6 ]

            Alex Cooksey added a comment - - edited

             

            Update - 01/11/2023

            Hi all,

            The behaviour described in this bug report is caused by an issue with Jira Server - "JRASERVER-75342 - Concurrent modification of single issue might result with stale values of its fields in index"

            We've worked with the Jira team on diagnosing and reproducing this problem - and the Jira team have committed to fix this problem shortly.

            However to set expectations - I don't imagine this fix will be resolved before 9.13 / 5.13 Code Freeze and subsequent release in early December - so will be targeting a fix for early 2024. 

            Please follow the Jira Server bug report linked above for future updates from the team on their release. 

            Thanks for your understanding,

            Alex
            Jira Service Management

             

            Alex Cooksey added a comment - - edited   Update - 01/11/2023 Hi all, The behaviour described in this bug report is caused by an issue with Jira Server - " JRASERVER-75342 - Concurrent modification of single issue might result with stale values of its fields in index" We've worked with the Jira team on diagnosing and reproducing this problem - and the Jira team have committed to fix this problem shortly. However to set expectations - I don't imagine this fix will be resolved before 9.13 / 5.13 Code Freeze and subsequent release in early December - so will be targeting a fix for early 2024.  Please follow the Jira Server bug report linked above for future updates from the team on their release.   Thanks for your understanding, Alex Jira Service Management  
            Bartosz Ornatowski made changes -
            Assignee New: Alex Cooksey [ da0dd4439f59 ]
            SET Analytics Bot made changes -
            UIS Original: 64 New: 60
            Kamil Cichy (Inactive) made changes -
            Remote Link New: This issue links to "Page (Confluence)" [ 829560 ]

              da0dd4439f59 Alex Cooksey
              9dec92182c8f AviGhosh
              Affected customers:
              27 This affects my team
              Watchers:
              34 Start watching this issue

                Created:
                Updated:
                Resolved: