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  1. Jira Service Management Data Center
  2. JSDSERVER-1540

JSD default/generated workflow, "Resolve this issue" transition is firing Generic Event

      NOTE: This bug report is for JIRA Service Desk Server. Using JIRA Service Desk Cloud? See the corresponding bug report.

      Summary

      Resolve/Close request transitions in a Service Desk instance do not trigger the appropriate notifications to Agents/JIRA Users according to the notification scheme.

      Steps to Reproduce

      1. Define users/groups under the Issue Resolved and/or Issue Closed notification settings of a Service Desk project's notification scheme.
      2. Create a Service Desk request in the Service Desk of step 1
      3. Resolve the request of step 2

      Expected Results

      The users or members of the group as defined under step 1 should receive notifications of the request being resolved

      Actual Results

      The members of the group or entities do not receive any notifications of the request resolution

      Root cause

      In the Service Desk default generated workflow, the transition that resolves requests fires a Generic Event in the transition post-functions.
      The notification scheme however acts on the Issue Resolved event. Since this is not defined in the post-functions, no notifications will be send.

      Workaround

      There are 2 possible workarounds for this issue.

      1. Add the users/groups in the notification scheme to the "Generic Event" instead of the "Issue Resolved" notification. This will however trigger notifications on all Generic Events within that project to the defined user/groups
      2. In the relevant workflows, change the "Fire a Generic event" to "Fire a Issue Resolved event". Ensure you do this for all resolve issue transitions in all workflows, and do not forget to publish the workflows after the changes have been made in order for the changes to take effect

            [JSDSERVER-1540] JSD default/generated workflow, "Resolve this issue" transition is firing Generic Event

            Andy Brook added a comment -

            This is also the case for re-opening issues.

            Andy Brook added a comment - This is also the case for re-opening issues.

            Yeah, this wasted a few hours of my day. It's an easy enough thing to fix... but when you're looking at the notification scheme it really isn't intuitive to think that the underlying workflow would do anything other than emit the intuitively correct event. I'm not certain this is isolated to JSD, though. I have some other workflows that I also noted emitted Generic.

            (Note: I wouldn't have been wrestling to wire up a convoluted notification system if JSD supported multiple issue types via email. The single issue type was a non-starter for me, since I have some issues that need to get escalated for pager response and some that don't. So I had to revert to "core JIRA" to handle email intake, which resulted in having to wire up email notifications to a bunch of gmail stuff with filters and groups to try to catch/file appropriately.)

            Roger Gonzalez added a comment - Yeah, this wasted a few hours of my day. It's an easy enough thing to fix... but when you're looking at the notification scheme it really isn't intuitive to think that the underlying workflow would do anything other than emit the intuitively correct event. I'm not certain this is isolated to JSD, though. I have some other workflows that I also noted emitted Generic. (Note: I wouldn't have been wrestling to wire up a convoluted notification system if JSD supported multiple issue types via email. The single issue type was a non-starter for me, since I have some issues that need to get escalated for pager response and some that don't. So I had to revert to "core JIRA" to handle email intake, which resulted in having to wire up email notifications to a bunch of gmail stuff with filters and groups to try to catch/file appropriately.)

              aolrich Andrea
              mfahd Fahd
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              1 This affects my team
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                Created:
                Updated:
                Resolved: