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  1. Jira Data Center
  2. JRASERVER-69646

Jira returns incoherent search results on Service Desk queues, Agile boards and issue search

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    Description

      Issue Summary

      Jira returns incoherent search results. The problem manifests on Service Desk queues, Agile boards and issue search.

      At this stage, we believe this is not a Jira bug but a misuse of API. Jira API changed in version 8 and some add-ons don't properly use Jira API.
      The issue does not appears always and in every instance, even with the same add-ons installed.

      Steps to Reproduce

      • Service Desk queues
        1. Go to Service Desk project > Queues
        2. Go to one queue and observe the issue count
        3. Switch to another queue
      • Agile boards
        1. Go to an Agile board that contains swimlanes
        2. Move ticket from one swimlanes to another
        3. Observe the result
      • JQL search - issue list
        1. Open an issue list and apply JQL search
        2. Observe the number of returned results
        3. Keep refreshing the page and observe results

      Expected Results

      • Service Desk queues:
        • Queues display correct and the same issue counts while navigating through queues
      • Agile boards:
        • Moving tickets between swimlanes works as expected
      • Issue list:
        • Issue list JQL search return the same results every time upon page refresh

      Actual Results

      • Service Desk queues
        • Ticket count changes while “jumping” from one queue to another. Let’s say we have “Unassigned issues” queue with issue count 5; after focusing on “All open” issue queue, the number changes to 4
      • Agile boards
        • When moving tickets from one swimlane to another, the ticket does not move (although its status has changed)
      • Issue lists:
        • After applying JQL search, issue list showing different different number of results with each refresh

      Notes

      Currently, on several instances, we noticed this behaviour being caused by one of the following add-ons:

      • Eazy BI
        • upgrading the add-on to the latest version should resolve the issue
      • Elements Copy & Sync
        • the fix was implemented in version 2.17.2
        • see the bug ticket for more information CS-1419:_ Inconsistent search results in Jira 8 with Copy & Sync_
      • PII Protector for Jira
        • No fix yet

      Probable cause

      A plugin calls thread searcher context but never closes the context. Affected threads are using this old context which contains a snapshot of data from the time when this context was opened. As a result, the user observes issues "jumping" back and forth on boards, Service Desk queues and other issue lists.

      Workaround

      Follow the workaround from Inconsistent Search Results in Jira 8.X:

      To confirm if one of custom add-ons is causing the issue:

      1. Stop Jira
      2. Remove the add-on .jar file from <JIRA_HOME>/plugins/installed-plugins directory
      3. Go to <JIRA_HOME>/plugins directory and remove the contents of .osgi-plugins and .bundled-plugins directory
      4. Restart JIRA
      5. Perform a full locked re-indexing
      6. Check if the issue still appears

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              Unassigned Unassigned
              mfilipan Marko Filipan
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              Dates

                Created:
                Updated:
                Resolved: