Uploaded image for project: 'Jira Server and Data Center'
  1. Jira Server and Data Center
  2. JRASERVER-59012

Thumbnail fails with some attachments

    XMLWordPrintable

    Details

      Description

      Summary

      After attach an image to JIRA, the thumbnail fails to render and generate a stacktrace in logs.

      Steps to Reproduce

      1. Download the image attached to this ticket (image.jpg)
      2. Create an issue in JIRA and attach the image during the creation

      Expected Results

      We should see the thumbnail of the image in the ticket.

      Actual Results

      The thumbnail is not working. However, if you open the image, it works.
      The below exception is thrown in the atlassian-jira.log file:

      Caused by: java.awt.image.RasterFormatException: negative or zero height
      

      Also checked the thumbs folder from the ticket created and seems to be empty.

      Notes

      This was tested in JIRA 6.3.9 as well and it worked there. Based on that, I tested JAVA 8 in JIRA 6.3.9 (the default is JAVA 7), and also tested JAVA 7 in JIRA 6.4.12 (default is JAVA 8), but found the same results (works only in JIRA 6.3.9 despite the JAVA version).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              aquadrospetry Andre Quadros Petry (Inactive)
              Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: