Uploaded image for project: 'Jira Server and Data Center'
  1. Jira Server and Data Center
  2. JRASERVER-47681

JIRA REST API 'api/2/issue/createmeta' not returning all custom fields for a project

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Needs Triage (View Workflow)
    • Priority: Medium
    • Resolution: Unresolved
    • Affects Version/s: 7.0.0
    • Fix Version/s: None
    • Component/s: REST API
    • Labels:

      Description

      I created 3 custom fields in a single project. (See attached image) Assigned 1 of the fields to the 'Create Issue' & 'Edit/View Issue' screens and the other 2 fields to just the 'Edit/View Issue' screen. When I call /api/2/issue/createmeta?projectKeys=TEST&expand=projects.issuetypes.fields only the custom field declared on the 'Create Issue Screen' (Field A) is returned. The other 2 custom fields (Field B & Field C) are not returned. This seems like a bug. All 3 custom fields are declared to the same project, just on different screens.

      I've attached the JSON returned from '/api/2/issue/createmeta' too.

      Version I'm using: v7.0.0-OD-08-001#70107-sha1:2554118

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                oakley.brandon+hipchat1931196052 Brandon Oakley
              • Votes:
                22 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated: