Uploaded image for project: 'Jira Server and Data Center'
  1. Jira Server and Data Center
  2. JRASERVER-45793

Update JIRA PostgreSQL JDBC driver

    XMLWordPrintable

Details

    • Suggestion
    • Status: Closed (View Workflow)
    • Resolution: Duplicate
    • None
    • None
    • None
    • We collect Jira feedback from various sources, and we evaluate what we've collected when planning our product roadmap. To understand how this piece of feedback will be reviewed, see our Implementation of New Features Policy.

    Description

      NOTE: This suggestion is for JIRA Server. Using JIRA Cloud? See the corresponding suggestion.

      i haven't tried Jira 7 yet, but in Jira 6.4.12 the JDBC driver version is postgresql-9.0-801.jdbc4.jar and this is really old.

      Even Confluence has been shipping JDBC postgresql-9.4-1202-jdbc41.jar.

      We are using PostgreSQL 9.4 right now, so pushing JIRA's bundled JDBC to as close to 9.4 driver would be ideal.

      I am not sure why JIRA is still behind Confluence.

      As a matter of fact, why is Confluence's bundling it under CONF_INSTALL/confluence/WEB-INF/lib while Jira is bundling JDBC under JIRA_INSTALL/lib/

      Thanks.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              38e5be2ccadb John Wong
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: