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Bug
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Resolution: Fixed
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Low
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6.2.2, 6.2.7
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6.02
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Summary
We set a limit for text fields through jira.text.field.character.limit. However, if we send an email to a project that has an incoming mail handler, and add enough text in the body to go past the limit, the bug is still created with a description that is over the limit.
If you then go to edit the issue's description field and don't change anything, the limit kicks in and it won't let you save it.
The mail handler should obey the limits on the text fields.
Steps to Reproduce
- Setup a of something to test with, say 10k.
- Restart the instance and verify the limit is in place.
- Send through an email with more than 10k in the body (baconipsum.com is good for this).
Expected Results
The email is not created.
Actual Results
The email is created, ignoring the jira.text.field.character.limit.
Workaround
To work around it we've added a regexp validator on the workflow that we normally have problems with, but it would be nice if the global setting was, you know, global.
- causes
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JRASERVER-28519 JIRA dies with OutOfMemoryException when rendering issues with numerous and/or large comments
- Closed
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JDEV-29780 Loading...
- is blocked by
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JRASERVER-40633 Error when comment contains N-1 characters and a newline and character limit is set to N
- Closed