Improve JIRA logging level to better report wrong username attribute

XMLWordPrintable

    • Type: Suggestion
    • Resolution: Won't Do
    • None
    • Component/s: None

      NOTE: This suggestion is for JIRA Server. Using JIRA Cloud? See the corresponding suggestion.

      Summary:

      When LDAP integration is set using Internal Directory with LDAP Authentication and the wrong attribute is set at the User Name Attribute field (it can be a dummy attribute) the following message is thrown into the atlassian-jira-security.log file:

      2013-06-14 18:16:02,970 http-8090-3 anonymous 1096x345x1 12rcd8y 127.0.0.1 /rest/gadget/1.0/login login : 'user_01' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.
      

      The problem:

      The message in the log can be easily misunderstood and lead the investigation to the wrong path. Also, when the authentication fail, the Current Failed Login Count increases, which reinforce the idea the that the LDAP user was found and the login failed by other reasons.

              Assignee:
              Unassigned
              Reporter:
              Tiago Comasseto
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Created:
                Updated:
                Resolved: