Uploaded image for project: 'Jira Server and Data Center'
  1. Jira Server and Data Center
  2. JRASERVER-32441

Searching with * only searches for alphanumeric characters

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Needs Triage (View Workflow)
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: 5.2.7
    • Fix Version/s: None
    • Component/s: JQL
    • Labels:

      Description

      In order to test this,

      1. create a custom field type : Text
      2. create an issue and add alphanumeric values to the custom field (for example, I added bh_ab123,bh_abc,bh12aaa,BH_AGENT)
      3. try searching by "Device name" ~ 'bh*' you get the output with all Device name values
      4. try searching with "Device name" ~ 'bh_*' you will get only one value : bh_ab123

        Attachments

        1. Screen shot 2013-04-04 at 1.05.20 PM.png
          Screen shot 2013-04-04 at 1.05.20 PM.png
          40 kB
        2. Screen shot 2013-04-04 at 1.03.41 PM.png
          Screen shot 2013-04-04 at 1.03.41 PM.png
          68 kB
        3. fls-with-star.jpg
          fls-with-star.jpg
          115 kB
        4. fls-without-star.jpg
          fls-without-star.jpg
          135 kB

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              rtandon@atlassian.com Ruchi Tandon
              Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated: