Details

      Description

      When a user comments on an issue via the comment button at the top or in the comment window at the bottom the wheel continuously spins. The comment is found to have been successfully added when the user hits refresh in the browser. This was reproduced in Firefox 17.0.1 and Chrome 23.0.1271.97 under multiple users on multiple workstations. When using workflow buttons this problem doesn't occur.

      catalina.out shows the following message:

      "com.atlassian.mywork.client.reliability.DefaultUnreliableWorker:thread-1 WARN <username> 941x62x1 16zb5b2 <workstation ip address> /rest/api/2/issue/<issue key>/comment [apache.commons.httpclient.HttpMethodBase] Going to buffer response body of large or unknown size.  Using getResponseBodyAsStream instead is recommended."
      

      This problem was first noticed Friday after upgrading from 5.2.2 to 5.2.6.

      A restart of JIRA did not resolve the problem.

      Important Note about this bug report

      This bug report has become conflated with two separate issues:

      1. The original report that "adding comments" was broken.
      2. The spamming of logs by the "Going to buffer response body of large or unknown size." message.

      This particular issue (JRA-31786) should be taken as the report that adding comments was broken.
      This was dealt with in a support case and seems to have been caused by a particular version of a third-party plugin.
      And hence is resolved as "Tracked Elsewhere".

      The log spam in JIRA has now been raised separately as JRA-37562

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              jared.campbell Jared Campbell
              Votes:
              1 Vote for this issue
              Watchers:
              37 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: