Uploaded image for project: 'Jira Data Center'
  1. Jira Data Center
  2. JRASERVER-27839

"Business Value" and "Story Points" are not exported when going through Views > Excel (All fields).

    XMLWordPrintable

Details

    Description

      NOTE: This bug report is for JIRA Server. Using JIRA Cloud? See the corresponding bug report.

      Symptoms

      When exporting all fields to Excel (XLS) the "Business Value" and "Story Points" are missing.
      Even when adding them manually to the columns (Tools > Configure Columns) this won't work.
      It also occurs with or without the presence of data on these fields.

      Steps to reproduce

      • Go to "Issues";
      • Click on "Search";
      • Click on "Views";
      • Select "Excel (All fields)"

      The generated XLS file won't export the "Business Value" and "Story Points" columns.

      Diagnosis

      The behaviour seems to be because the custom fields "Story Points" or "Business Value" are not valid for at least one of the issues which are returned by the search.

      Workaround

      Option 1: Modify the query to include only issues which have "Story Points" or "Business Value"

      Modify the query to filter only issues for which the custom fields "Story Points" or "Business Value" are valid by appending the following to the query:

      AND ("Story Points" is EMPTY or "Story Points" is not EMPTY)
      

      or

      AND ("Business Value" is EMPTY or "Business Value" is not EMPTY)
      

      Option 2: Add "Story Points" and/or "Business Value" to all issue types and projects

      Note that this could have global impact on your JIRA since it affects configuration for all issue types and projects.

      1. Go to JIRA Administration > Issues > Custom Fields.
      2. Scroll down to "Story Points" and from the gear wheel icon, click on Configure.
      3. For "Choose applicable issue types", select "Any issue type" or choose all issue types which might be returned as part of the search.
      4. For "Choose applicable context", select "Global context" or choose specific projects that are included in the search.
      5. Press "Modify" to save the configuration

      The workarounds are thanks to this thread on Atlassian Answers.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              fdefreitas FernandoA
              Votes:
              12 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: