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Suggestion
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Resolution: Unresolved
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None
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1
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Summary
User is unable to see the delete Button on the board even if the user has the delete issue permission
Environment
Jira Cloud
Diagnosis
When a user clicks on the three dots of a ticket on the Kanban Board, they are unable to see the delete button. However, when the user opens the same ticket in a separate window, the delete button is visible.
Cause
There are multiple projects included in the board filter query. In one of these projects, the user was missing the delete issue permission, which prevented them from seeing the delete option on the board. However, when the user opened the same ticket in a separate window, they were able to see the delete button. This is because, in that scenario, the system only checks the user's permissions for that specific project, rather than the configuration of the board.
Board Filter query:
Solution
Upon investigation, we have found that in the Board filter if more than one project is present the you should have delete permission on all the projects in order to delete the issue option on the board for all the tickets
Expected
Boards have the capability to assess the specific permissions associated with individual issues. They will display the options to Delete and Archive within the Board if a user possesses the necessary permissions to delete that particular issue, even if the user lacks permissions to delete all issues within the Board.